discourse forums disallow reply by email after days setting

Answering this thread specifically(?) using email cant be done, It give this error:

We’re sorry, but your email message to [“discoursereplies+redacted@whonix.org”] (titled Re: [Whonix Forum] [Website] Long Wiki Edits Thread) didn’t work.
We only accept replies to original notifications for 90 days. Please visit the topic to continue the conversation.

Is there a way to extend replies time? (maybe even infinite?)

1 Like

Done. Now set to 0 which means infinite.

Careful with publishing any strings with any hashes. In this case, it might be possible to impersonate you.

1 Like

Awesome! , Good point thanks alot +1

1 Like

same issue.

We’re sorry, but your email message to [“discoursereplies+xxx@whonix.org”] (titled Re: [Whonix Forum] [Support] Torbrowser not starting) didn’t work. We only accept replies to original notifications for 90 days. Please visit the topic to continue the conversation.

1 Like

Did you reply from the same e-mail address that was receiving the notification?

To complicate matters, I’ve experienced that Thunderbird confuses which e-mail to sent from. It say one thing but uses actually a different SMTP server which would then be rejected.

The discourse error message might be wrong:

Yeah im sure about it.

I dont know if thunderbird sent from another email, But there is no log in the server say the same error if i give you the time i have sent my email and to which topic? (12:04 AM UTC)

maybe from there things are clearer. (if its easy to investigate about it)

1 Like

Discourse has a log on processed e-mails built-in. Not sure this is included. Searching by time doesn’t work but but I could look at the e-mail address it was sent to. Could you please post the first 4 random strings or the e-mail you replied to?



1 Like


Testing a longer e-mail reply. A short reply of mine “test reply by
e-mail” was rejected.

Just writing one short line alone might be insufficient.

If you can see this, try to reply with a longer text by e-mail too.
Approximately same length as I am using or longer.

1 Like
1 Like

Logging of such e-mail issues also broken upstream.

1 Like

In Thunderbird when using multiple e-mail addresses, one has to send from the e-mail address used to sign up for the discourse forum. But in the e-mail Write button (e-mail draft window) choosing using From: does not mean much. It’s just a textual string. It doesn’t mean that the corresponding SMTP server will be used. For example if someone had both, a microsoft e-mail address and a google mail address, setting From: to the microsoft e-mail address doesn’t mean that the microsoft SMTP server would be used for outgoing e-mail.

Under Thunderbird -> Edit -> Account settings -> Outgoing Server (SMTP) the default server might be used. Could be settings issue or Thunderbird bug.

I recommend against using multiple SMTP servers in Thunderbird. These are easily confused through settings or bug from one to another.

1 Like

To avoid issues for replying to a forum thread by e-mail:
If using Thunderbird, do not use the Reply button. Use the Reply All button, if available.
Whatever button used: make sure reply is to discoursereplies+6e5f0f[redacted]@whonix.org (which has a chance of working) and not to discourse@whonix.org which is guaranteed to fail.

1 Like

The forum software upgrade today might have improved the situation. Please test.

1 Like


test mail

Patrick via Whonix Forum:

1 Like