[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

disable pulseadio in the workstation in addition to the gateway?

I noticed that pulseaudio was removed from the gateway. Has there been a fix found for pulseaudio/apparmor, perhaps something in “apparmor-profile-everything”? For those of use who don’t really play video and audio files, is there a way to disable/remove pulseaudio from the workstation? Thanks

Assuming you mean pulseaudio being used for sandbox escapes or other vulnerabilities, no. Pulseaudio access control is still a work in progress https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/Developer/AccessControl/

Run

sudo apt-get purge non-qubes-vm-audio alsa-utils pulseaudio pavucontrol

and disable audio in the VM settings.

For Virtualbox go to Settings -> Audio -> Enable Audio and un-tick it.

For virt-manager, go to the “i” symbol -> Sound device -> Remove.

2 Likes
2 Likes
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]