disable hwclock-save.service


ID: 335
PHID: PHID-TASK-c7gxikkiqw2ea67uxoyy
Author: Patrick
Status at Migration Time: open
Priority at Migration Time: Wishlist


Quote Tails issue tracker:

systemd (215-13)'s debian/changelog entry says:

Add hwclock-save.service to sync the system clock to the hardware clock on shutdown, to provide monotonic time for reboots. (Note: this is a hack for jessie; the next Debian release will enable timesyncd by default). (Closes: #755722)

We need to disable that, as per our design goal to avoid leaving traces on the hardware being used, as much as possible.

For more information, see https://bugs.debian.org/755722. (And interestingly, there we learn that under sysvinit (Wheezy), util-linux’s hwclock.sh is supposed to “overwrite the RTC with the system clock partway through the shutdown”, so that’s not exactly a regression against Tails/Wheezy, but rather a problem we already had. Will file a dedicated ticket about it.)