[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Debian Testing + Whonix 9.2 ''ACPI S3 not supported''

Hello people.
Im using Debian Testing and fresh Whonix 9.2 with KVM from testing repository
libvirt-bin 1.2.7-11
qemu-kvm 2.1+dfsg-4
virt-manager 0.9.5-1

i do all steps like whonix KVM manual said except newer version kvm not from wheezy backports,but jessie and have such errors

Error starting domain: unsupported configuration: setting ACPI S3 not supported
Details
Error starting domain: unsupported configuration: setting ACPI S3 not supported

Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/asyncjob.py”, line 96, in cb_wrapper
callback(asyncjob, *args, **kwargs)
File “/usr/share/virt-manager/virtManager/asyncjob.py”, line 117, in tmpcb
callback(*args, **kwargs)
File “/usr/share/virt-manager/virtManager/domain.py”, line 1160, in startup
self._backend.create()
File “/usr/lib/python2.7/dist-packages/libvirt.py”, line 951, in create
if ret == -1: raise libvirtError (‘virDomainCreate() failed’, dom=self)
libvirtError: unsupported configuration: setting ACPI S3 not supported

I already read these two topics with similar problems

https://www.whonix.org/forum/index.php/topic,386.15.html
https://www.whonix.org/forum/index.php?topic=420.0

tryed to delete these lines,like Patrick mention but this not help

Im thinking maybe its just because of newer version of KVM,if it will be from wheezy backports this would start working?

Maybe there is a solution by editing .xml Whonix files,thanks.

Is this a fatal error when starting Whonix? Are you able to get to your desktop at all or are you stuck in the startup stage.

Yes,stuck in the startup stage.No desktop startup at all.I do small research and maybe its because of kernel,just not supported?

There is quite a number of KVM Debian users around here. If its something major, I would have seen more bug reports.

I think its probably a KVM bug in Jessie or maybe a Whonix error related to interrupting the start up phase on first launch. The latter could cause permanent problems.

My advice to you is to report the KVM bug to Debian maintainers so they’ll fix it in time for Jessie’s stable release. Meanwhile use Wheezy backports if it works for you.

Could be related to the kernel.

Also a good way to figure out if this issue is caused by Whonix or would also happen with Debian is by using non-Whonix, plain Debian VMs. Then apply these settings. See if it works. If not, that is actually good. Because help requests and bug reports always have so much better chances if you strip out other maintainers believing “someone else’s (Whonix’s) fault, not ours”.

Whonix error related to interrupting the start up phase on first launch
I doubt that interrupting Whonix can cause this. VM images are not supposed to disrupt what KVM does on the host. If anything Whonix images was able to change anything related to KVM on the host, that would be a grave bug in KVM.
I doubt that interrupting Whonix can cause this. VM images are not supposed to disrupt what KVM does on the host. If anything Whonix images was able to change anything related to KVM on the host, that would be a grave bug in KVM.

Not what I meant. I was talking about interruption of the guest init during the setting up phase, corrupting something causing this.

How do you guys using wheezy-backports if virt-manager is not in the repository,i just mark this.

What if install qemu-kvm libvirt-bin from wheezy-backports and virt-manager from jessie,does someone try such thing?

I think its not problem of Whonix,i also use older version,also upgraded kernel to linux-image-3.16-2-686-pae now have other errors.

I will report this bug to Debian,when tried all possible working ways.As i see there is quite a few people who using or interested in KVM,i guess most using virtualbox.

How do you guys using wheezy-backports if virt-manager is not in the repository,i just mark this.
Not sure what you mean. But instructions on using wheezy-backports - this supposed you are using wheezy - is documented here: https://www.whonix.org/wiki/KVM#Debian_stable (click expand)
What if install qemu-kvm libvirt-bin from wheezy-backports and virt-manager from jessie,does someone try such thing?
Risks breaking package manager.
As i see there is quite a few people who using or interested in KVM,i guess most using virtualbox.
This is likely because KVM (and Qubes) are not appropriately presented on the https://www.whonix.org/wiki/Download page. We need a redesign of that page. Which is not easy due to the big amount of information, there are so many options. Difficult to suit everyone. More info: https://www.whonix.org/wiki/Dev/Download_Wizard - I plan to start a discussion about that with all maintainers (VBox, PhyIso which is be; KVM; Qubes) soon.

Sorry i lost password for that account,this one mine second,i mean that virt-manager not currently in wheezy-backports,maybe whonix kvm article was written when it was,but now its missed.

This is likely because KVM (and Qubes) are not appropriately presented on the https://www.whonix.org/wiki/Download page. We need a redesign of that page. Which is not easy due to the big amount of information, there are so many options. Difficult to suit everyone. More info: https://www.whonix.org/wiki/Dev/Download_Wizard - I plan to start a discussion about that with all maintainers (VBox, PhyIso which is be; KVM; Qubes) soon.

Thats for good.

Is there a way to put .qcow2 images to non /var/lib/libvirt/images/ but home,you need too much space in root directory for vms?

But it is in wheezy:
https://packages.debian.org/wheezy/virt-manager
And that is sufficient.

(Using wheezy-backports repository is an addition, not a replacement to the wheezy repository.)

Please post a separate topic so we don’t mix up this one.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]