[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Debian stable issue #3: this qemu doesn't support the rng-random backend

My version numbers are the same as https://www.whonix.org/wiki/KVM#Debian_stable (click expand and scroll down to check version numbers).

Leaving

    <rng model='virtio'>
      <backend model='random'>/dev/random</backend>
    </rng>

will result in this error

Error starting domain: unsupported configuration: this qemu doesn't support the rng-random backend

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 66, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1114, in startup
    self._backend.create()
  File "/usr/lib/python2.7/dist-packages/libvirt.py", line 866, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: unsupported configuration: this qemu doesn't support the rng-random backend

Removing

    <rng model='virtio'>
      <backend model='random'>/dev/random</backend>
    </rng>

suppresses that error, but as we agreed, this is no solution, rng should be enabled.

But there are 2 more debian stable related issues, that I will post in separate threads. So maybe we don’t have to make this change, but can fix the root of this issue.

This issue is likely unrelated to installed virt-manager version, because it also happens when attempting to start the VM using virsh.

error: Failed to start domain Whonix-Gateway error: unsupported configuration: this qemu doesn't support the rng-random backend

Any update on this?
I don’t feel comfortable suppressing the error if it’s going to cause some sort of security concern.

News yes, but only bad news.

Unsupported. (https://www.whonix.org/wiki/FAQ#What_do_you_mean_by_unsupported.3F)

Update: QEMU support is deprecated in favor of KVM. The slow performance of pure emulation makes it non practical for most of the Linux user base. The majority of consumer systems should support the hardware virtualization extensions required by KVM.

Apologies. I forgot to run this command and I think it was causing my issue (I’m using KVM):

If you are running Debian Stable (Jessie) you will run into a libvirt bug that conflicts with the way it works with Apparmor and the VM will refuse to start. It was fixed upstream but it will be a while until it reaches you.

To fix it run:

sudo ln -s /etc/apparmor.d/libvirt/TEMPLATE.qemu /etc/apparmor.d/libvirt/TEMPLATE.kvm

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]