[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Debian stable issue #2: <pm> causes Error "setting ACPI S3 not supported"

My version numbers are the same as https://www.whonix.org/wiki/KVM#Debian_stable (click expand and scroll down to check version numbers).

Leaving

  <pm>
    <suspend-to-mem enabled='no'/>
    <suspend-to-disk enabled='no'/>
  </pm>

will result in this error

Error starting domain: unsupported configuration: setting ACPI S3 not supported

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 66, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1114, in startup
    self._backend.create()
  File "/usr/lib/python2.7/dist-packages/libvirt.py", line 866, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: unsupported configuration: setting ACPI S3 not supported

Removing the … block solves that issue.

But there are 2 more debian stable related issues, that I will post in separate threads. So maybe we don’t have to make this change, but can fix the root of this issue.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]