CRITICAL: X won't start after yesterdays debian upgrade


After I did yesterdays dist-upgrade X no longer starts!

I start virtual box, it does all the checks and goes to "KDE starts in 10 seconds"
after that it dumps me to the terminal where I can login.

Trying to start X says that it fails and mentions looking for driver.
I noticed it’s starting using an apparmour profile, so thught it might be something whonix specific since I couldn’t find the exact same problem for debian.

Xorg -configure and trying the new profile file doesn’t work either.

TLDR: Last debian upgrade brakes whonix and the GUI doesn’t start anymore. No other reports on that so might be somehting apparmour related.

Anyone else? I doubt I’m the only one with that issue.

whonix WS desktop environment not loading

same issue here.

was able to get it running properly by selecting advanced startup options and using the first linux 3.x distribution.


you mean the 3.x kernel? Ah I didn’t think of that.
Already started a older backup version and I’m afraid to update now.

I can’t believe no one else is chimming in on this?


Found a possible solution: https://wiki.debian.org/DebianTesting

As of 2016-07-14, upgrading to Stretch from Jessie seems to remove some packages that are needed to run Gnome, and you may end up simply at a command prompt. To restore Gnome, log in as root and:

apt-get --reinstall install gdm3
apt-get --reinstall install gnome
apt-get --reinstall install gnome-shell
dpkg-reconfigure gdm3

Other packages may also need re-installing, use the reinstall option as above if you discover errors.


Is this about Whonix 13? What has this to do with Debian stretch?


In the past, Whonix has referred to Debian support for general support
issues (like desktop not loading). The 4.x kernel was introduced with
stretch so it is my belief that the issues may be related.

If I am barking up the wrong tree, please redirect me so that we may figure
this out the correct way. Danke.


You are using the wrong version of Whonix most likely. Use Whonix 13 until Whonix 14 is blessed stable.

Jessie has no 4.x https://packages.debian.org/jessie/linux-base. Whonix 13 is jessie based.

Whonix 14 is developers-only. Install Whonix only by following through https://www.whonix.org! Not through any other links.


I am a 12 user that upgraded to 13. Per the whonix-check, I use the following for system updates:
sudo apt-get update && sudo apt-get dist-upgrade -y

I’ve not screwed with apt sources or anything like that.


can we upgrade with sudo apt-get update && sudo apt-get dist-upgrade as per the whonixcheck wihtout breaking it now or not?

whonix 13 here


I upgraded Whonix 13. Nothing broke.


Ok I just did it again to test. Got a backup of whonix before the last update and crash and updated again.
Workstations does the same, after restarted doesnt start the X but just the terminal.

The gateway I didnt update lasst time but did now and seems to works fine.

Seems like there are only few users having this issue so far.


i ran an older vm, last updated in april and updated it via the usual whonixcheck instructed commands.

i noticed some small errors during update (updated WS and GW simulatously so i put the blame on GW restarting a network module while WS was still downloading).

everything was fine. but now when i start the WS, it just leads me to the command line interface.

i urgently need to access my pgp keys and some documents, that i left in the desktop environment. can somebody tell me how i can fix this?



Same here. Seems there are few of us.

Any guide on what is wrong with just our installs?


I’m going to guess that at some point, the repos got messed up. It was likely a very short period of time as the people that have complained about this all popped up around the same time. I know I’ve not changed the apt list from default and only upgraded per the instructions (sudo apt-get update && sudo apt-get dist-upgrade -y).

I popped a snapshot and tried the reinstall commands mentioned above. They don’t work (duh) but I was hoping they would be a starting point for discussion.

Long story short: some people did their normal apt-get update && dist-upgrades and ended up with 4.9 kernels on the workstation. During that same time period, it appears that they did not get hit with the same on the gateway. I understand this shouldn’t have happened but am curious what may have caused it, if there is any known reason/explanation.


Well I updated a backup few days later and it also broke. So that excludes that.
However, it’s odd that there is no solution after so much time.

Should we just download the latest whonix and start from scratch?


I’ve got my old box still running but also have the new one. I’m curious as
to why this happened but haven’t had enough time to really dig in. The only
thing I can think of that changed related to repos on my box is the
electrum install, which I used the instructions provided in the will to


I also have electrum installed on the VM that broke.


I’ve had the same issue happen to me at the same time @Dani first posted. Since then I have not been able to get on the WS’s “current snapshot”. I’ve had to refresh from an old snapshot. I can save snapshots each time but if I try current it fails to load GUI. I’m left at a login screen in CLI but none of my pw seem to work. I’ve saved all the logs, or whatever you call them, from konsole. I’ll try to paste them here as a link but i’m a newb so…might take a min to figure out how that’s done.


Tested and can confirm. Electrum’s apt pinning is the problem. It’s worth noting that right now the Money Wiki specifically warns about an issue with the electrum install guide and references back to this thread.

@Patrick Can you do another run-through and back up/correct me on this? Do we have a “best-practices” workaround/solution to this?