[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Connectivity problems in poor network environment

I use ISP service who is known to artificially limit network traffic. I noticed this as I have trouble during connection initiation to Tor when I use Whonix in virtual machines and I don’t have the same issue if I use another network provider. When I try to connect to a website on Workstation I open wireshark on the host system and observe many ICMP packets with notice “Destination Unreachable(fragmentation needed)” sent from nodes inside ISP’s network. Sometimes I can connect succesfully to websites, most of the times I can’t.

But if I use tor browser on my host machine to connect to the very same sites I have no problem at all. Connection is successful 100% of times and I see only a few destination unreachable packets.

I guess I have a problem with particular obfs4 bridges on whonix? Once I couldn’t use whonix at all because it didn’t find bridges in torrc available for use even in networks with no latency issues. I spontaneously fixed it with reconfiguring tor connection settings and choosing obfs4 transport once again in tor settings. Old bridges were replaced with new ones.


Tor Generic Bug Reproduction required.

I tried running systemcheck or whonixcheck because this is how it’s called on my whonix version. If I type whonixcheck in console it says it cannot find the script. The same thing happens if I launch it with GUI.
whereis command reports it is located in /usr/bin/whonixcheck and when I run “file /usr/bin/whonixcheck” it outputs “broken symbolic link to systemcheck”. I also have /usr/lib/whonixcheck directory as whereis says and I have whonixcheck script file inside it. When I launch it outputs “whonixcheck script bug” with “error_cause: error handler signal ERR detected with BASH_COMMAND: touch /run/whonixcheck/${IDENTIFIER}_running”

I’ll try installing and testing non whonix VM connectivity later

Yes. Was renamed to systemcheck. Typing whonixcheck should still be functional due to compatibly symlink.

Where did you download Whonix from?

That seems outdated. There is no such reference in the source code anymore in the current Whonix version.

At the rate you’re having strange issues which nobody else is reporting I suspect you’ve downloaded an old Whonix version from somewhere else?

I suggest to re-install Whonix and download Whonix from whonix.org.

I had an issue like that before and reinstalling whonix helped me back then.

I downloaded whonix from whonix dot org website and verify it with signature

Several times I upgraded whonix with “apt update && apt upgrade” instead of sudo apt-get update && sudo apt-get dist-upgrade. Maybe this was the cause of problems?

Upgrading without sudo/root isn’t possible. That cannot be the issue.

Upgrading can cause issues but should not. If that was to happen, then many users would report the same issues. Upgrading is important.

Given the situation, for Whonix 16 stable release of consider Whonix 16.0.0.8 (Debian 11 bullseye based) - for VirtualBox - Major Release - Testers Wanted!.

I used apt with sudo to upgrade software. I omitted sudo in my post above.

This is the first time I report problems with open source software to maintainers. All other times in the past I just was too lazy to do this but had a reason to do this. I suspect there are many users like me. But this is whole different topic

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]