[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Connection problem


#1

I’ve installed Whonix 14 on KVM (I’m using Archlinux) following the step by step official guide. The problem is, when I run the Anon Connection Wizard and try to start the connection the process stops at 5% during the Tor bootstrapping phase (Bootstrap phase: connecting to a relay directory). If I try and run Whonixcheck I recive a warning that tells me that there no route to host. The host system uses a VPN to connect to the internet, I’ve tried switching it off but nothing happened, also, the DNS setting on the host is to use Stubby, a DNS over TLS proxy, that works perfectly anyway, so I don’t think thats the problem.
What can I do to solve this issue? Thanks in advance.


#2

The Whonix gateway can’t connect to the internet for whatever reason. Maybe firewall or virtual network settings on the host? Does networking work on other virtual machines?


#4

Ok, I may be stupid, I’ve tried other VMs and none seem to connect correctly. I’m trying to troubleshoot this right now. My firewall allows all connections to the internet but blocks incoming connections, I think that’s fine.


#5

Now I have another problem, libvirtd stopped working and now it refuses to start


#6

Now libvirt works, I’m still not able to connect any VM to the internet and I can’t find anything useful on Google. Any suggestion?


#7

How about disabling the VPN on the host and checking if everything works normally?

Whonix Gateway support tunneling the Tor connection through a VPN in a leak proof way.

If you have still have problems on the host, you will have to ask your VPN provider for support.


#8

I’ve tried with the VPN disabled and nothing changed


#9

At the moment this issue is not related to Whonix. You might get better support on the Arch Linux forum. Just some ideas: Disable the VPN. Disable every custom firewall options on the host, libvirt will usually try to set some iptables rules for networking itself. Check that the libvirt default network is active and working. Check the usual stuff like logs, ping the VM or use wireshark to see if any traffic gets in or out of the machines, dump traffic on the interface of the VM as well as on the hosts native interface. Check the network interface in the VM. Does it get an IP address? Maybe try using a different driver for the network adapter.
As soon as you get non-Whonix VMs working Whonix should work, too.


#10

Nalnowtad:

My firewall allows all connections to the internet but blocks incoming connections, I think that’s fine.

Yes.