Connect gateway with custom-debian-workstation (and default workstation crush)

I use whonix a few year, and i really appreciate developers work, but after update to whonix 15 my workstation die. Every new workstation 15-version did the same after second or third launch. I dont think its fault of whonix, more likely its some rare bug of virtualbox.
Therefore i try to make new custom workstation based of debian. I used this instruction https://www_whonix_org/wiki/Other_Operating_Systems with 100% - precision
but i cant communicate my WS with standart gateway. In addition i cant whonificate another WM that was installed from netinst-iso.

So, this instruction is actual or maybe something changed? I really broke my mind trying to solve this problem.

A custom Debian WS is possible. You need to first off set the networking according to the wiki. The most important points are that for the WS, you need an internal networking interface with its gateway address set to .So no dhcp. Also, if your workstation does not use as its internal ip, you will need to update that in the Gateway.Firewall rules on WS will need to be updated so that packets can be appropriately redirected.
What bug were you experiencing in Virtualbox?


That is an insufficient description. No guarantee help can be provided but if you want to try, see:

This is a bad approach. Rather than working on root causes, falling back to workarounds which might come with more issues than you’re avoiding.

I install gateway and workstation, make my new gateway the terminal-only. Than i run WS, add locales and install one pocket(just messanger) and reboot or shutdown. Thats all i do. But i noticed that in this period WS work a little slowly than usual, on version 14 and 13. On the second launch, after only a few second it freeze all my system so that i cant move the mouse. And in the end virtualbox said that WS make critical error and shoud be stopped.

Can you tell a little more details, please?

1 Like

VirtualBox version? Outdated?

Such bugs can be reported to They are probably going to request VBox.log. See these bug report instructions:

[Solved] auto-resize Guest Display stopped working in Linux -

No, it isnt. All soft is a latest version.

Thank you. I think it will take a lot of time.
May be it will much better if i just have to try change my host from debian to qubes a little later. Its look like a solution of all problems.
Now i need quick and easy decision. So i will be pleasured if you can help with the main question of the topic.

Thank you! Now everythig work. I just changed to Someone need to make a little fix in instruction)

Where does it say where it should say

You could suggest an edit. See wiki footer:

This is a wiki. Want to improve this page? Help is welcome and volunteer contributions are happily considered! Read, understand and agree to Conditions for Contributions to Whonix ™, then Edit! Edits are held for moderation.

1 Like

Great; I’m glad you got it working.
Regarding the IP addresses; on a default Gateway, it is configured to work with a Workstation that has an address of
If you wanted a custom Workstation, you could make it have any IP you choose (just make sure it is in the subnet). You would have to modify the Gateway’s network config file to recognize the new address by simply commenting out the default, and replacing it with your own. That is what I meant.
With the iptables rules, in a regular, default Gateway and Workstation pair, the Workstation redirects its packets to the Gateway through a series of rules using the “REDIRECT” flag. I was suggesting to you that if you want to emulate the default Workstation with your custom one, then carefully take a look at the Gateway’s iptables ruleset. You can do this by going to terminal (in Gateway) and typing:
sudo iptables -v -n -L --line-numbers
You will see all the rules that direct traffic. Don’t change anything, but use those rules to craft your own rules for your custom Workstation. There are a few ways you can accomplish this. I suggest you read up on Iptables and its syntax. It is not hard at all.
Glad everything is up and running!