[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Confusion with NoScript in the Tor browser in Whonix Workstation

It seems to me that a lot of javascript code is still running in my browser e.g. when I search in DuckDuckGo, it fills in search matches as I type.

Isn’t the usual behavior of NoScript to block this?

On the left there is a little icon. If you click it you get a selection menu with an entry security settings. There are 3 options. The lowest allows all scripts to run. The highest disables script as default. It is linked to the noscript settings.

By default javascript is enabled in Tor Browser.

https://whonix.org/wiki/Tor_Browser#Security_vs_Usability_Trade-off

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]