[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Configuring Onion Service

https://gofile.io/?c=xb6Z6O

There’s no need for that. VirtualBox guest addition are installed default. And using the iso can cause some unrelated issues.
( VirtualBox Guest Additions )


Your /etc/tor/torrc looks wrong. This is how original torrc as shipped by Whonix looks:

Just a single line %include /etc/torrc.d/ plus comments

Did you add %include /etc/torrc.d/95_whonix.conf to /etc/tor/torrc?

That should be removed. To open that file in an editor:

lxsudo mousepad /etc/tor/torrc

Looks like you’ve updated from developers repository since only that contains the improved anon-verify. It shows:

4 files are used as Tor configuration files: \
/usr/share/tor/tor-service-defaults-torrc /etc/tor/torrc /etc/torrc.d/95_whonix.conf /etc/torrc.d/95_whonix.conf\

Meaning `/etc/torrc.d/95_whonix.conf` is parsed twice which results in parsing that file twice which configures the hidden service. That's the root cause.


At this point in time developers repository might be OK but I discourage to keep using it. To switch to another repository, see:

  1. Whonix stable depository there was used ALL TIME…previously.
  2. If VirtualBox Guest Additions ARE INSTALLED DEFAULT why they not worked and bidirectional exchange not functioned without manipulations I wrote above ?

I never made any modification of:

/etc/tor/torrc

I have not amnesia :slight_smile:

Bug.

https://www.whonix.org/wiki/Dev/VirtualBox#VirtualBox_Guest_Additions_Bugs

Ok.

I found a bug in anon-connection-wizard function repair_torrc. Will work on it.

I made all corrections indicated above and after reload Tor got something interesting you can find inside attached file.

https://gofile.io/?c=L77hTD

Really cool system. Incredible properties. I’ll recommend it to all my friends.

user@host:~$ sudo cat /var/lib/tor/hidden_service/hostname
[sudo] password for user:
cat: /var/lib/tor/hidden_service/hostname: No such file or directory

Restart. Not reload. If Tor is not running yet, you cannot reload Tor (or any systemd unit file) if not yet running.

https://www.whonix.org/wiki/Tor#Restart_Tor

Expected. First, Tor needs to start without error. If an error like that is shown, Tor won’t start and not create these files.

At last onion domain has been obtained. Thank you !!!

Glad this could be solved. Will be fixed in next release out of the box which will probably come soonish.

But our goal was to configure Onion Service. Headache not stopped.

File
sudo nano /usr/local/etc/torrc.d/50_user.conf

there was transformed to such content:

HiddenServiceDir /var/lib/tor/hidden_service/
#HiddenServicePort 80 10.152.152.11:80
HiddenServicePort 80 192.168.0.11:8070
HiddenServiceVersion 3

Into workstation there was installed

apt-get install lighttpd

to config there was added:

server.port = 8070
$HTTP[“remoteip”] !~ “80 192.168.0.11” {
url.access-deny = ( “” )
}
server.dir-listing = “disable”

and

server.document-root = “/var/www/html”

was not changed.

Tor services was restarted and reloaded.
Light server (above):

user@host:~$ sudo service lighttpd start

Try to enter ONION WEB SITE from different computer:

Outcome ----> “Hmm. We’re having trouble finding that site…”

The same manipulations on Kali Linux only with difference:

HiddenServiceDir /var/lib/tor/hidden_service/
HiddenServicePort 80 127.0.0.1:8080

and

server.port  = 8080
$HTTP["remoteip"] !~ "127.0.0.1" {
url.access-deny  = ( "" )
}

AND ALL FUNCTIONING WITHOUT HEADACHE.

Where is error ?

Also there was impossible obtain workable onion web site with gateway with:

File
sudo nano /usr/local/etc/torrc.d/50_user.conf

HiddenServiceDir /var/lib/tor/hidden_service/
HiddenServicePort 80 10.152.152.11:80
HiddenServiceVersion 3

and server

server.port  = 80
$HTTP["remoteip"] !~ "10.152.152.11" {
url.access-deny  = ( "" )
}

Other lines the same.

And …?

Please follow these instructions:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]