Changing hostname of gateway? (Whonixcheck gets mad)


I have a setup where multiple gateways are on the same network. To avoid problems I changed the hostname when I changed the IP address for the other gateways. For example, instead of the IP would be for one of the extra gateways.

This setup works and I have tested it. My only problem is that Whonixcheck complains that the hostname has changed. I really like Whonixcheck and want to keep it enabled but I don’t like seeing the errors all the time. Is there any way to get Whonixcheck to be okay with this without hacking the source? I’m worried if I hack the source I won’t get updates.


Don’t know.

Is this what you intended? If your goal is isolation, shouldn’t they be on separate networks? On different networks, they don’t need new IPs or Hostnames per: Multiple Whonix-Workstation ™

That address is not reserved for Private IPs. In fact, it resolves to “DoD Network Information Center” (DoD = US Dept of Defense). Very active web spider, apparently.

I tried that and it didn’t seem to work I can try again. It didn’t seem to like multiple servers with the same IP address.

Answering to your first post. Interesting! Possible using whonixcheck settings.

whonixcheck_skip_functions+=" check_hostname "

See also:

Thank you Patrick for the help and for working on Whonix. I’ll report back with some information once I get it working.