[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Changes to the documentation

These are some changes I would make to the documentation unless someone has a better idea:

Include the version numbers (of Ubuntu, Torbrowser, etc) that the documentation applies to. If the first editor writes the documentation for Ubuntu 12.04.3 then someone finds that nothing has changed with Ubuntu 12.04.4, they can change the introduction or section titles to Ubuntu 12.04.3/12.04.4.

Instead of sharing folders you can create iso’s to make files available in the virtual machines. With Linux you act like you are burning a data disk with Brasero, and it gives you the option to create an iso. Go to the virtual machine window menu > Devices > CD/DVD devices > Choose a virtual disk.

------ My experience with Ubuntu 14.04 -------

Host name could not be ubuntu. The installer said that name was in use. I suggest using “host” as is recommended for other operating systems. Host with a random number (like Host82938) might be a better option. No operating system will use that by default. If you want to connect workstations using (virtual) ethernet I don’t know if they need different host names.

Can’t have US for country with UTC for timezone. Have to choose “other” to have UTC as an option.

When I disabled USB, VirtualBox says there are inconsistent settings unless I change the setting under System > Motherboard > Pointing device to PS/2 Mouse.

Without Guest Additions the screen resolution is 640x480. At:

…it says to add /etc/X11/xorg.conf.d/00-virtualbox-monitor.conf for Whonix

There was no change in resolution in Ubuntu 14. With the screen at 640x480 Torbrowser and Firefox didn’t open in their usual sizes. I believe this would mean any web browser would have a very unique fingerprint. I enabled workspaces under System Settings > Appearance > Behavior tab. This allows me to use CTRL + ALT + arrows to see larger windows but I don’t think there is any way to resize Torbrowser or Firefox to a common size. I would just add this information and let the user decide if the security risk of Guest Additions…

… is worth having a non-unique web browser fingerprint or something that may require a larger screen to be usable at all.

These are some changes I would make to the documentation unless someone has a better idea:
Thanks a lot for your ideas!
Include the version numbers (of Ubuntu, Torbrowser, etc) that the documentation applies to. If the first editor writes the documentation for Ubuntu 12.04.3 then someone finds that nothing has changed with Ubuntu 12.04.4, they can change the introduction or section titles to Ubuntu 12.04.3/12.04.4.
As long there is nothing version specific at all, not that I know of for now, I would prefer omitting it. If you wish to get more opinion on that, please feel free to create a separate topic in the development sub forum for just that suggestion.
Instead of sharing folders you can create iso's to make files available in the virtual machines. With Linux you act like you are burning a data disk with Brasero, and it gives you the option to create an iso. Go to the virtual machine window menu > Devices > CD/DVD devices > Choose a virtual disk.
This is documented here: https://www.whonix.org/wiki/File_Transfer#Transfer_files_from_the_Host_into_Whonix-Gateway_or_Whonix-Workstation_through_ISO_images

https://www.whonix.org/wiki/VirtualBox_Guest_Additions links to it.

(Alternatives
For file exchange with Whonix without installing guest additions, see File Transfer.)

Maybe that isn’t well linked?

Host name could not be ubuntu. The installer said that name was in use. I suggest using "host" as is recommended for other operating systems. Host with a random number (like Host82938) might be a better option. No operating system will use that by default.
This isn't as simple as a documentation change.

Anonymized operating system user name “user”, /etc/hostname, /etc/hosts, /var/lib/dbus/machine-id, which should be shared among all anonymity
distributions. See also:

I would like to get an agreement with other anonymity distributions. Tails apparently agreed with hostname “host”, but Freepto made a different suggestion (http://lists.autistici.org/message/20140627.215105.24023267.en.html). Please join the existing discussions if you want to suggest adding random numbers to “host”.

I guess best for now would be suggesting hostname “host”. Please change that if it’s not already hostname “host”.

If you want to connect workstations using (virtual) ethernet I don't know if they need different host names.
Not that I know. Both Whonix-Gateway and Whonix-Workstation are using hostname "host".
Can't have US for country with UTC for timezone. Have to choose "other" to have UTC as an option.
Please clarify this in documentation.
When I disabled USB, VirtualBox says there are inconsistent settings unless I change the setting under System > Motherboard > Pointing device to PS/2 Mouse.
Without Guest Additions the screen resolution is 640x480.
Really? That's weird. I thought it defaults to 1024x768. It always did when I installed Ubuntu in VirtualBox.

When it’s 640x480, can you increase it?

Please install x11-xserver-utils.

sudo apt-get update sudo apt-get install x11-xserver-utils

Then post the output of xrandr (without guest additions).

https://www.whonix.org/wiki/Higher_Screen_Resolution
That wiki page should only help to get resolutions higher than 1024x768. I don't know it's required for 1024x768 itself.
...it says to add /etc/X11/xorg.conf.d/00-virtualbox-monitor.conf for Whonix
Should be general Debian (and Debian based such as Ubuntu) related instructions, unspecific to Whonix.
There was no change in resolution in Ubuntu 14.
This is very host operating system / perhaps even hardware specific. And really difficult either way. Can't help with the https://www.whonix.org/wiki/Higher_Screen_Resolution method (was contributed by an anonymous user).
With the screen at 640x480 Torbrowser and Firefox didn't open in their usual sizes.
Totally unusable, I think.
I believe this would mean any web browser would have a very unique fingerprint.
Yes, I wouldn't recommend using it that way.
I would just add this information and let the user decide if the security risk of Guest Additions...
I wouldn't advice to install guest additions because of 640x480 resolution. I would prefer if we sorted out your issue with no having 1024x768 resolution without guest additions. You're the first one who reports such an issue.

Would like to tell, what version of host operating system, VirtualBox version and guest operating system you are using?

The Whonix-Default/Download-Workstation does not have this issue with only being at 640x480 resolution? It’s 1024x768 by default? Maybe Ubuntu devs have introduced a new issue in a newer version?

VirtualBox 4.3.12.

Guest is Ubuntu 14.04.0 64 bit installed with the graphical live DVD. There are two places where you can select to use free software. One is at the first boot prompt. The second is during installation. I installed twice using the opposite options wherever possible. One is free software for both options, one is non-free for both.

Really? That’s weird. I thought it defaults to 1024x768. It always did when I installed Ubuntu in VirtualBox.[/quote]

From a web search you can see that many people have this problem with 14.04. I’m going through some of those solutions now.

Guess what? I fixed it without installing Guest Additions. After I installed the non-free version of Ubuntu I noticed that its pointer was auto captured. I hadn’t manually installed any Guest Additions at this point. After install it booted this way. Then the free software virtual machine magically had auto-captured pointer! Later I installed the proprietary driver on the non-free virtual machine and this changed the other virtual machine! Isn’t that convenient? When I boot the free software VM and look at Software & Updates > Additional drivers it says no proprietary drivers are in use and the search says no drivers available (those sources are not enabled on this VM). I guess I could try removing the non-free VM or uninstalling the driver over there and see what it does to both.

I wrote the rest of this post before I installed the video driver.

No. When I go to Display, there is no other option. I checked both my Ubuntu VMs (one is supposed to be only free software).

Instead of a model it says “Built-in Display”.

[quote=“Patrick, post:2, topic:356”]Then post the output of xrandr (without guest additions).

xrandr
user@host:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
   640x480        73.0* 
user@host:~$ 

My Whonix WS VMs are 1024x768.

[quote=“Patrick, post:2, topic:356”]This is documented here:

https://www.whonix.org/wiki/VirtualBox_Guest_Additions links to it.

(Alternatives
For file exchange with Whonix without installing guest additions, see File Transfer.)

Maybe that isn’t well linked?[/quote]

It is perfect, I just overlooked it. I added the part about Brasero since it is easier than installing and using the command line. I see there are many ways to transfer files. Thanks!

This sounds like guest additions got installed by default. Please check this.

Should yield no results. If it lists virtualbox-guest-x11, then guest additions have been installed by default.

This is probably not what happened. I found I made a change to xdiagnose and changing any of the options under “Debug” makes the screen 1024x768 after a reboot. I don’t think it was necessary to install the video driver to have 1024x768.

[quote=“Patrick, post:4, topic:356”][quote author=nufflel link=topic=374.msg2774#msg2774 date=1405198534]
Guess what? I fixed it without installing Guest Additions. After I installed the non-free version of Ubuntu I noticed that its pointer was auto captured.
[/quote]
This sounds like guest additions got installed by default. Please check this.

Should yield no results. If it lists virtualbox-guest-x11, then guest additions have been installed by default.[/quote]

I tried this on the two Ubuntu VMs and it was the same no matter the screen resolution or if the pointer was being auto captured, I got this result on all of those snapshots:

user@host:~$ dpkg -l | grep virtualbox
ii  unity-scope-virtualbox                                0.1+13.10.20130723-0ubuntu1                         all          VirtualBox scope for Unity
user@host:~$ 

Not sure if that is a security risk.

After installing the video driver I got these three (only on the VM where I installed the video driver which is not surprising now that I believe xdiagnose changed the resolution capability):

virtualbox-guest-dkms
virtualbox-guest-utils
virtualbox-guest-x11

Probably unity-scope-virtualbox is no security risk. It just helps searching for installed VirtualBox VMs.

I was able to reproduce the 640x480 resolution problem. This is a bug introduced by Ubuntu. With that many VirtualBox users and people who try Ubuntu in VirtualBox first, I am wondering why they don’t even make a rudimentary VirtualBox compatibility check before release. Let’s hope this bug has not been introduced in latest Debian testing as well.

Once after reboot I just saw 640x480 but couldn’t see anything useful. The screen was all mixed up, all colorful, but that was about it. Switching virtual terminal back and forth, Virtual Box host key + F1; Virtual Box host key + F7, fixed it. Really strange.

xdiagnose was able to fix the issue for me as well. Although this is just a workaround. Can you check please if this issue has been reported as a bug at Ubuntu already?

One thing is very interesting. Mouse integration is functional, even if virtualbox-guest-x11 isn’t installed. And it even works in terminal! Might be interesting to add in Whonix-Default/Debian-Workstation as well. I am wondering how it’s implemented?

Ubuntu uses launchpad for their bugs

https://help.ubuntu.com/community/ReportingBugs#How_to_report_bugs

…and it has been reported there:

https://lists.launchpad.net/kernel-packages/msg48175.html

It is not on VirtualBox bugtracker.

https://www.virtualbox.org/search?q=640x480+ubuntu&noquickjump=1&ticket=on&changeset=on&wiki=on

I guess others consider this to be a bug in Ubuntu 14 not VirtualBox.

I just tested and mouse integration ceased to work when I disabled USB and changed System > Pointing device > USB tablet to PS/2 mouse. I bet you didn’t disable USB as the wiki recommends.

I haven’t been having problems with the keystrokes being ignored on the Whonix gateway or Ubuntu since I enabled USB and USB tablet pointing device for the Ubuntu 14 VM, a few days ago. If it starts doing that again I should add to the documentation that this may happen if you disable USB.

Just in case anyone took note of my paranoid theory:

So this was probably wrong also. I probably enabled USB or used a snapshot that did. No evidence of one VM altering another or that using the “free software” options makes any difference to these issues.

https://lists.launchpad.net/kernel-packages/msg48175.html
Something went wrong with that bug report. It can only be found on the mailing list but not in the bug tracker. I've maybe notified Sayantan, if I found the one who made that report. Hopefully he reports again to get a proper bug report.

[quote=“nufflel, post:7, topic:356”][quote author=Patrick link=topic=374.msg2803#msg2803 date=1405307680]
One thing is very interesting. Mouse integration is functional, even if virtualbox-guest-x11 isn’t installed. And it even works in terminal! Might be interesting to add in Whonix-Default/Debian-Workstation as well. I am wondering how it’s implemented?
[/quote]

I just tested and mouse integration ceased to work when I disabled USB and changed System > Pointing device > USB tablet to PS/2 mouse. I bet you didn’t disable USB as the wiki recommends.[/quote]
Confirmed.

I haven't been having problems with the keystrokes being ignored on the Whonix gateway or Ubuntu since I enabled USB and USB tablet pointing device for the Ubuntu 14 VM, a few days ago. If it starts doing that again I should add to the documentation that this may happen if you disable USB.
This is problematic, because by default we recommend to leave USB disabled.

Added mouse integration without installing guest additions to documentation:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]