Can't update... The repository ' focal Release' does not have a Release file.

it’s a few days I can’t neither check for updates with whonixcheck nor with the terminal.

Any ideas?

Thank you.

Welcome to Whonix forums and thank you for your question!

That’s an issue with that third party repository. Contact the maintainer of that repository. Not a Whonix specific issue.

Can be sported as per Free Support for Whonix ™

Hi Patrick.
Thank you for your very kind reply.

I’m not an expert, all I know is that from the terminal I just typed “sudo apt-get-update-plus dist-upgrade” and if there was an update, it was installed.
Unfortunately here I can’t type the real links but I get this:
Ign:2 h t t p ppa launchpad net / fixnix / netspeed / ubuntu focal InRelease
Err:4 h t t p ppa launchpad net / fixnix / netspeed / ubuntu focal Release
404 Not Found [IP: 80]
Hit:5 h t t p s deb whonix org buster InRelease
Hit:1 tor+https: cdn aws deb debian org /debian-security buster/ updates InRelease
Hit:3 tor+https: cdn aws deb debian org/debian buster InRelease
Reading package lists…
E: The repository ‘http ppa launchpad net/fixnix/netspeed/ubuntu focal Release’ does not have a Release file.

What should I do?
Please help…
Thank you!!!

Contact the owner of the link that is down.

Or remove that repository.

1 Like

Please forgive the noob question: can I edit some file to fix the problem?
What should I edit and what should I write as link?
Thank you.


sudoedit /etc/apt/sources.list

Or if that one is empty or non-existing, some file in the drop-in folder:


Documentation warns against foreign sources:
Install Additional Software Safely

A ppa is a foreign source.

Could as well as delete the VM and start with a new one. Because removing the repository fixes the apt error but doesn’t remove installed software which would then rotten since no longer updated.

You need basic linux knowledge. Whonix is a small linux distribution that cannot teach essential stuff such as this. See this page for better option to get help:

Hi Patrick.
Thank you for your patience.
With your help, I’ve been able to fix my problem: I had a “strange” .list in ```

Thank you again!