Whonix Wiki Download Docs News Support Tips Issues Contribute DONATE

Can't SSH to VPS in Whonix

Hey so I used to be able to SSH into VPS servers in an Oracle Virtual Box Whonix Workstation. Suddenly it stopped working.

I tried:
-Different VPS providers
-Deleting my VMs and recreating Whonix

The error I get is Connection Refused or Connection timeout.
All the Websites on the Tor Browser work, just not SSH

Who is setting up the SSH server?

A VPS with VirtualBox?

Who is installing VIrtualBox on the VPS? The provider or you?

If you are setting up the SSH server… How do you do it? As per Onion Services - Whonix? If so, please confirm you’re able to set up a hidden web server as a prerequisite exercise beforehand.

The Hosting Provider setup the SSH server and KVM.
The VPS is NOT virtualbox, but KVM. However I am using VirtualBox on my local PC to run Whonix.

While I can’t SSH via Whonix, I can put Tor on a router, and SSH in on my local VirtualBox “non-whonix” Kicksecure. So the VPS provider is not rejecting Tor and the issue has something to do with Whonix itself.

Also I tried Whonix SSH with a second DIFFERENT VPS provider and faced the same issue.

Works for me.

ssh whonix.org

Expected printout:

The authenticity of host ‘whonix.org (’ can’t be established.
ED25519 key fingerprint is SHA256:tsvKWEuUwbP0vx+vrePlMqbC4qUXn5fscrm/lZLhVrE.
Are you sure you want to continue connecting (yes/no/[fingerprint])?

No need to login, try any further.

Could you try the same command please for testing?

(Privacy related: You could replace whonix.org with any other server but I don’t think it matters for privacy if it’s over Tor anyhow. The server is getting tons of malicious bot login attempts every day anyhow just like any public server. But that server is surely online and functional.)

Sometimes it works and sometimes it doesn’t

when I do whonix org it gives the same output as you about the fingerprint. but then on my own VPS it gives port 22: connection refused.

But then it will randomly work again in 2 days

So SSH is functional in principle.

Your VPS is most likely blocking connections from the Tor network.

A post was split to a new topic: terminal freezes after SSH login to VPS