Can't install MultiBit

I’ve installed openjdk-7-jdk and when try to install multibit with the command
java -jar multibit-0.5.17-linux.jar i get all this

No protocol specified Exception in thread "main" java.lang.NoClassDefFoundError: Could not initialize class sun.awt.X11GraphicsEnvironment at java.lang.Class.forName0(Native Method) at java.lang.Class.forName( at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment( at sun.swing.SwingUtilities2.isLocalDisplay( at javax.swing.plaf.metal.MetalLookAndFeel.initComponentDefaults( at javax.swing.plaf.basic.BasicLookAndFeel.getDefaults( at javax.swing.plaf.metal.MetalLookAndFeel.getDefaults( at javax.swing.UIManager.setLookAndFeel( at javax.swing.UIManager.setLookAndFeel( at javax.swing.UIManager.initializeDefaultLAF( at javax.swing.UIManager.initialize( at javax.swing.UIManager.maybeInitialize( at javax.swing.UIManager.getUI( at javax.swing.JOptionPane.updateUI( at javax.swing.JOptionPane.<init>( at javax.swing.JOptionPane.showOptionDialog( at javax.swing.JOptionPane.showMessageDialog( at javax.swing.JOptionPane.showMessageDialog( at com.izforge.izpack.installer.GUIInstaller.showFatalError(Unknown Source) at com.izforge.izpack.installer.GUIInstaller.<init>(Unknown Source) at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance( at sun.reflect.DelegatingConstructorAccessorImpl.newInstance( at java.lang.reflect.Constructor.newInstance( at java.lang.Class.newInstance0( at java.lang.Class.newInstance( at com.izforge.izpack.installer.Installer.main(Unknown Source)

I don’t know multibit, haven’t tried either on Debian or in Whonix, but I see two possible causes for errors here.

How did you install openjdk? From Debian package sources? If not, uninstall what you installed. Then install from package sources.

sudo apt-get update sudo apt-get install openjdk-7-jre

That might work better.

Also “No protocol specified” might imply you tried to start a graphical user interface application as root, which is recommended against. Start is as user, without using sudo.

multibit instructions for Debian stable (currently: wheezy) should also work for Whonix (which is based on that Debian version).

I installed it with

sudo apt-get install openjdk-7-jdk
that’s what they recommend at

I see you’ve wrote
sudo apt-get install openjdk-7-jre

which I believe is the framework and they have recomended the development kit?
anyway, when i tried
sudo apt-get install openjdk-7-jre

it said
openjdk-7-jre is already the newest version.
openjdk-7-jre set to manually installed.

so i guess it installed it as dependency already?

after writing all this i just tried running the installer again and it worked

i guess i might have been root previous time, huh!

About the jre / jdk thing, follow them on this, not me. (jdk sounds more like toolkit indeed) My mistake.

Great that you got it working.

AFAIK jdk includes jre, so as long as they both are the same version, jre shall be enough to run Java bytecode. jdk is needed for compiling stuff from source.

Same problem, same solution.


I’ve got another issue with MB-HD/classic and Whonix.

I have electrum/MB-HD on Whonix.

MB-HD/MB-Classic on Host Osx.

I’ve got BTC on the Host when I paste the Wallet (s) address from the Whonix clients , the MB-HD on the host won’t accept it, says the wallet is invalid (well actually just goes red and won’t let you proceed). On the Classic it actually says not a valid address.

Which is weird because its a MB-HD generated address, just on Whonix.

I’ve also tried Electrum wallet address on Whonix, same issue both MB-HD and Classic.

Any thoughts?