[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Cant get GPG fingerprint in icedove email setup

Apologies if this is in the wrong category, i did look through them and was unsure where to put this…

I am following the installing a secure os guide, and given my inexperience, am quietly ‘chuffed’ to have made it this far…

however, i am on page 358 of the guide, and am attempting to import the GPG fingerprint for anonguide@vfemail.net which starts 6422… however 1 of 2 things keeps happening.

The first thing is it searches for the key, but doesn’t find anything at all…
The second thing is if its doesn’t do the above, i get a pop up informing me that

‘I am sorry, could not find any key that would match the specified search criteria.
Please note that key ID’s should be prefixed with “0x” (e.g. 0xABCDEF12)’

Have i done something wrong? i have followed the guide pretty strictly

If you’re talking about anonguide.cyberguerrilla.org, that’s a good guide to follow. Kudos for getting through it! IIRC, the author stops by here from time to time.

You’re in the wrong universe :slight_smile:
Here are some tag words to help you search for your solution (from the bottom-up):
GPG - Enigmail - Icedove - Thunderbird - Whonix - Debian

What you need to know is that the same GPG keyring is used for all GPG related activity on your Workstation, including by Enigmail. I would recommend starting with a beginner’s guide to GPG.

I have no idea what you did.
Some keyservers let you search for keys by strings like “ABCD1234”, others require you to search for “0xABCD1234”.

EDIT: “Here are some tag words to help you search for your solution” should have said “Here are some tag words to choose from to help you search for your solution”. You are presently looking in Whonix. You should be moving way down to look in GPG.

i am sorry to hear you are having an issue. the steps in the guide were typed up and the favorable results reproduced multiple times. there are a few issues that i could see being the culprit.

  1. did you follow steps 8-14 in chapter 4f correctly? if you didn’t, torbirdy may still be forcing a proxy connect to port 8118 that will fail.

  2. make sure you close icedove at step 72 before continuing on to step 73. icedove doesn’t completely clear the old proxy settigns enforced by torbirdy without doing this for some reason.

  3. it’s a possibility that the tor hidden service for the public key server, hkp://qdigse2yzvuglcix.onion, was unreachable at the moment. if the server is down, enigmail will tell you it can’t find the key, rather than informing you that it couldn’t connect to the server. were you able to import jacob appelbaum’s public key from the command line in step 5?

Thanks so much for the help troops, i do tend to run into minor hurdles but always get through them…I’ll head back to the guide and re-trace my steps.

Apologies for posting in the wrong section, i really wasn’t sure if it was a GPG related Issue, or a whonix related issue, i’ll make sure to follow proper protocol in future…

Thanks again

Update…

Ive just went through all the steps again, double checked but still cant get this to verify the key, Tempest yes ive checked the 3 items you listed, i have the jason appelbaum key imported no problem.

SIGHS<

No worries. Just giving you a hard time. It’s hard to know when you’re starting out.

When you’re troubleshooting, it’s better to provide too much information than not enough. I’d really like to help but I have no idea what you are doing… Please say which version of the guide you are using, and what # step you are on… The page number doesn’t seem to match up with what you are saying.

Guide says to search for key on web server, save as file, import file. This doesn’t match your description.


BTW, Tempest = the author. Thanks to him for the guide - I used it to get started with Whonix myself.

No worries, and i agree a bit thanks for the guide!.

The guide i am using is Version 1.0. February, 2016.

Im on Chapter 4f, Encrypted email with Icedove and Enigmail

I’m at step 74, which is showing as page 358…

  1. In the Key Management window that appeimported for Jacob Appelbaum if you chosClick on “Keyserver → Search for Keys.”

i do this, then enter 64222A88D25730910C47A904BD8083C5237F796B, and have hkp://qdigse2yzvuglcix.onion as the keyserver.

When i click ok, i get an enigmail alert stating 'I am sorry, could not find any key that would match the specified search criteria.
Please note that key ID’s should be prefixed with “0x” (e.g. 0xABCDEF12).

or, it searches continuously, endlessly!!

Hope this helps

Thanks, much better. I was still on version 0.9.4.

Ugh. I didn’t even realize this mess existed. (Feel free to skip these links:)
https://www.whonix.org/wiki/E-Mail#Icedove_.28Mozilla_Thunderbird.29_with_Enigmail_.2B_TorBirdy
GPG keyservers from within Whonix workstation

Most Whonix users use GPG through the command line or via the KGPG frontend (interface). Tempest’s guide walks you through “patching” TorBirdy so it will work seamlessly with Whonix. I don’t know which is more difficult: patching TorBirdy or learning to use another GPG interface. Like I said at the beginning, they all interact with the same backend system, GPG. In any case, it might be helpful to learn the other options since there will be times when you will want to use GPG without having Icedove available / configured properly.

For the guide, I tried it myself and it worked fine. Since you were able to use gpg from the cmd line, we can rule out network connectivity or keyserver issues. Most likely, you made a typo! :rage:

Start Icedove, go to Add-Ons, disable TorBirdy. Close Icedove.

cd ~/Downloads
rm torbirdy-current.xpi

Start again from Step 3. Copy/paste commands whenever possible. Make sure ‘//’ is at the beginning, in front of the double-quote.

Start Icedove, go to Add-Ons, Install from File. Close Icedove

Restart Icedove and try search again. You can search for “anonguide” instead of the big number (fingerprint).

After all that, if it still doesn’t work, re-install a clean torbirdy and use KGPG (in your KDE menu, Utilities).

Also, please accept my apologies… You were in the right place after all! Not a GPG issue - it’s a Whonix issue :slight_smile:

first, thank you both for the help and the feed back. also, i’m very glad you’ve both found the guide useful.

if using nano to edit the torbirdy config file is an issue, i could change that. perhaps with a gui editor to do a find and replace. i’ve thrown command line steps in the guide just so people will see a different way to do things.

as for using the command line or kgpg to import keys, that used to work fine. but, with the recent update to icedove, if icedove was running and a key was imported via the other steps, icedove wouldn’t see them. it required a refresh. all of the steps combined just seemed to be a bigger headache fr new users. so, it made sense to modify torbirdy to get around that.

if either of you think i can modify the guide to work better for that, please let me know.

To Tempest and Entropy…

Many MANY thanks for all your help, i went back through the steps frm step 3 and im now up and running!!.

I’ve also worked my way to the end of the guide, so am pretty chuffed now…

Thanks again for the support/guidance…

Next Step? lol:grin:

No, I think it’s just a case of “the eye sees what it wants to see.” Like me repeatedly typing in commands incorrectly despite staring at it…

Two things help with that I think: 1. explaining to users why they are doing what they’re doing (ie command line parameters; not obvious punctuation changes), 2. absent that, emphasizing copy/paste

That’s easy. Bit by bit or all at once…

Really a great resource… comprehensive, precise, clear
More impressive given that mostly written by non-native-English speaker.

thanks. i will throw a note about copy/paste in 1.0.3.

@tempest

Icedove 38.6.0, Enigmail 1.8.2:

  1. launched Icedove
  2. added new public key using KGpg
  3. composed new email, click send
  4. enigmail key selection dialog box presented Refresh Keys button
  5. newly added key available in enigmail

However, enigmail key management does not allow refresh.
Did not test decryption using newly added keys.

just so i understand, new key is not appearing in enigmail key management?

i am not entirely sure i understand the problem. i have not been able to reproduce it. regardless, i do not believe it has anything to do with the patch to torbirdy, which merely affects the proxy setting.

Sorry for lack of context. There is no problem - either with your guide or with icedove/enigmail.

Meh, I thought you said “Icedove required a restart”. Now I see you said “refresh”. So please disregard my earlier post. I was just pointing out that it was possible to refresh keys in Icedove without a restart.

  • Key Management: File Menu -> Reload Key Cache
  • Key Selection: Refresh Key List Button

IMO, I think it might be easier (and more useful) to teach KGpg and tell people to refresh if key doesn’t appear rather than using Enigmail Key Management and editing TorBirdy. Just my vote :slight_smile:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]