[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Can't get Gateway OVA working in VMware Workstation 10 or ESX 4.1

Hi,

The OVA imported fine to Workstation 10 (after relaxing requirements). When it tries to connect to TOR and get time sync is when I have a problem though.

What can I do to resolve this?

Message from logs is:
Tor Bootstrap result: Boostrapping for 58 seconds. 40 % done. Tor reports: NOTICE BOOTSTRAP PROGRESS=40 TAG=loading_keys SUMMARY="Loading authority key certs"
Whonixcheck gave up waiting after 61 seconds.

Have you seen https://www.whonix.org/wiki/VMware already?

I have. I spent a good bit of time trying to research this issue on my own before posting. The log messages don’t give me anything to go off of to further troubleshoot so I’m here asking for help.

I’m not sure what I should / could try to resolve this.

Does internet in other non-Whonix VMware VMs work for you?

Yes.

Problem is, there is no maintainer for Whonix VMware support. Since I am not a VMware user and my time is limited, fixing this is both simple and difficult. Simple, because most likely just a few VMware settings (just 1, 2 or 3 lines I predict) are wrong and difficult, because it’s hard to figure out which ones when doing “remote debugging” (=I ask you to run commands in the forum and you write back what the result was).

What happens if you run.

sudo service networking restart
sudo ifconfig

I just reminded myself, some time ago I wrote:

Bits of this may be useful to debug this situation.

Especially testing, if internet access to clearnet is working at all in that VM would be useful:

Looks good so far. Let’s see if clearnet access works.

(Warnings as per https://www.whonix.org/wiki/Troubleshooting#As_user_clearnet.)

And let’s see what Tor says. Messages at beginning and end could be interesting.

sudo service tor restart | less

Also see Tor log.

Could be interesting?

Yeah, good catch. That’s the reason why Tor does not work.

From Whonix wiki:
When the user powers on Whonix-Gateway and the host time is too much off, it will not be able to connect to the Tor network. It is advised, when powering on Whonix-Gateway, to check that the host time is no more than 1 hour in past or more than 3 hour in future. Otherwise Tor will be unable to connect. [https://lists.torproject.org/pipermail/tor-talk/2012-February/023264.html]

Is your host clock accurate enough? +/- 30 minutes is good enough.

Time is accurate. (It’s 16:51 right now)

Ok, time is right, but not for UTC.

I’m in CST.

Is this a bug? Shouldn’t it attempt to sync time?

a) what do others think what time in UTC is at time of writing
b) read your host clock in your native time zone
c) calculate your host time to utc
d) check Whonix-Gateway clock (UTC by default)

Now, a should equal c should equal d.

(No time zone changes required on your host for VirtualBox users. No such issue reported in a while.)

Timesync won’t work if clock is too much off, because timesync is done over Tor.

There is probably no bug. Time in Whonix VMs is to UTC on purpose.

Whonix’s build script is doing.

[code] ## Set system clock of VM to UTC.

When VirtualBox starts it looks up date and time of the host, i.e. “JAN 15 2012 00:00:00”

and sets the VM clock to that date and time. The following option translates the date

and time to UTC, thus hiding the hosts timezone from the guest.

sudo -u “$user_name” VBoxManage modifyvm “$VMNAME” --rtcuseutc on[/code]

My guess is, that VMware sets the VM to your host’s time zone. This is bad. Can you figure out how to set your VM clock to UTC?

VMware sets it upon import based on the local time zone of the client. No big deal, just make to override that value when you import the OVA and it’ll connect.

I’m downloading updates now.

Thanks for the fast assistance!

Can you tell please what steps one has to take to solve this? So we can add this to https://www.whonix.org/wiki/VMware?

I simply set the clock in Whonix to the correct time.

Now set for UTC time vs my local client time

This is discouraged. Whonix sets VM hardware in VM settings and system clock to UTC, so it is shared among all Whonix users and other anonymity distributions are using UTC as well. In case of timezone leaks, it’s just the shared UTC value and not your real time zone. Therefore I advice to figure out how to set the VM hardware clock to UTC.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]