Cannot start VM in host-live mode

I have installed Debian 10 to a USB drive, and then morphed it into KickSecure. I installed and configured Whonix KVM and have both of the Gateway and Workstation VMs in running condition.

However, when I try to start the VMs with KickSecure in live mode, I get an error message that says:

Error starting domain: internal error: child reported (status=125): unable to set user and group to ‘64055:64055’ on ‘/var/lib/libvirt/images/Whonix-Gateway.qcow2’ : No space left on device

I am wondering if maybe since they are sparse files that whatever operation (I’m assuming chown) that is being performed on them is basically undoing the sparse-ness (for lack of a better term) and trying to fill up the drive with the full 100 gb of the image. The USB drive I am using is only a 32 GB so this could definitely result in no free space being left.

Otherwise I have no idea why it is doing this, because I can write information to the ramdisk. I even ‘touched’ an empty file in the same directory as the .qcow2 image to make sure it was not somehow related to the path.

Host OS: Debian 10.10 Buster morphed to KickSecure
qemu-kvm: 1:3.1+dfsg-8+deb10u8

Yeah I think so too. I think we were progressing on this same problem for grub-live on the host, but I’m unsure as to what the status is now.

cc/ @Patrick


My apologies, I think I was unclear, because the issue you referenced seems to be for something unrelated to my issue.

I am trying to run the host in live mode, but when doing so I am unable to start the guest VMs.

Bullseye: live-boot needs GRUB_DISABLE_LINUX_UUID="true" parameter in /etc/grub.d/11_linux_live - #6 by Patrick is a general bug breaking this way earlier but solution avaialble.

This could be a KVM specific issue?

Or could be simply too less host RAM. But even then, above might help.

//cc @onion_knight

1 Like

Hmm okay, I tried to follow that discussion but am a little unsure I understood. I tried installing the whonix-libvirt package on my KickSecure host to get those systemd services installed, but afterwards I encountered the same behavior when trying to start the gateway VM. Should I have tried to set these services up manually instead?

I suppose it could be too little RAM. I only have 8 GB on this machine. Still I would have thought that would be enough to run the host in live mode and also at least boot the gateway VM.

@Patrick was this fixed in If so I’ll make a new build in a few days. Hopefully I’ll confirm the cli mode fix by then.

Yes but also before also fixed after stable upgrades. If stable upgrades don’t fix it, a new build likely won’t fix it either.

I had a little bit of time to experiment and read this thread a little bit more closely.


I set the permissions on the .qcow image files to 0444 while in persistent-boot mode, and then rebooted the host to live-mode. After that, both VMs started up fine.

So I suppose installing the whonix-libvirt package simply did not work as I had expected. I might try to setup the systemd services manually later to test, but for now I am satisfied with simply manually changing the permissions back and forth.


[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]