[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Cannot run Whonix Gateway- problem with VirtualBox

Hi all,

After importing the .ova into VirtualBox, I tried to boot it up, but I keep getting the message

VT-X is disabled in the BIOS. (VERR_VMX_MSR_VMXON_DISABLED).

Details

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

This seems really odd to me since I have no issue at all with running other 32-bit Debian based systems in VBox (Tails, Ubuntu and Debian itself run perfectly fine). I’ve used Whonix before on different hardware and I never ran into this issue…

My machine is 32-bit with an Intel processor. Once by mistake I downloaded a 64-bit version of some distro, and upon booting in VBox I got the same message, which was obviously due to incompatibility. It seems like that shouldn’t be the case here though…

I checked my BIOS and there doesn’t even seem to be any options about VT-X

Can anybody advise?

Thanks

Then your system is maybe too old and has no VT-X. Try disabling it. See also:
https://www.whonix.org/wiki/Starting_Whonix

Does that work?

Also, in my Dell PCs’ BIOS the “Virtualization” setting (under menu item “Performance”) was set to “off”, by default, and had to be manually enabled, and VT-x is not explicitly mentioned, but that’s what it was. When that setting was off, my computers tested as having no VT-x, and when virtualization was manually enabled, they passed the VT-x test.

Disabling the "Enable PAE/NX " option didn’t seem to make any difference

So I went to BIOS, Config -> CPU and saw a menu of four choices. The bottom two were

Intel® Virtualization Technology [DISABLED]

Intel® VT-d Feature [DISABLED]

I tried to change them, but strangely the menu only let me navigate through the first two choices (I can’t recall them now but they didn’t seem to have anything to do with virtualization), nothing seemed to let me access the bottom choices…

Any idea why that might be and how to fix that?

Thanks for the lightning fast responses btw

I would speculate, that perhaps your BIOS supports it but your CPU does not.

Sorry, previously I falsely suggested to disable PAE. Not that it interferes here (also worth trying), but primarily VT-x/AMD-V needs to be disabled here.

Updated in the wiki. Please see and try:
https://www.whonix.org/wiki/Starting_Whonix#VERR_VMX_MSR_VMXON_DISABLED

Please report if that worked. (If disabled VT-x/AMD-V worked, or if also nested paging needed to be disabled.)

So I Enabled PAE/NX, and disabled the “Enable VT-X/AMD-V,” and it seems to be working just fine!

It’s an i5 processor from about 4 years ago by the way, not that old or weak

Thanks!

Mines an Intel Core 2 Duo, at least 8 years old.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]