[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Cannot import Whonix-Gateway.ova to VirtualBox


#1

When I try to import appliance, I cannot find the required Whonix-Gateway.ova file nowhere in the PC. Also, when I go into the OS, I get an error message that says “Failed to start mounts VirtualBox during start” and when I try to log in the software only blinks and nothing else. What did I mess up in and how can I fix this?

Thank you.


#2

Good day,

The browser you used to download the image should usually tell you in which folder the gateway has been placed.

Could you make a screenshot? And are you sure that that is how the error message is phrased?

Have a nice day,

Ego


#3

I used Google Chrome and this is the message VirtualBox displays:

There is no file under .ova only:
Whonix-Installer.exe
ego.asc
Whonix-Installer.exe.asc and,
VirtualBox-5.1.14-1123924-Win.exe

These are all the downloaded files that were correlated to this process oh and GPG.

Thank you.


#4

Good day,

Oh, you are trying to use the Installer? In that case, their should be no requirement for a seperate .ova file for the Gateway. Neither do you need a seperate Installer for Virtualbox.

Simply follow these instructions: https://www.whonix.org/wiki/Windows

There is no need for separately installing VirtualBox, nor for importing any images anymore.

Have a nice day,

Ego


#5

Great! And what about the error message? Also, I’m curious, what exactly were you thinking was my situation?

There still might be a problem because the when I enter login the VM simply blinks and doesn’t do nothing else.

Thank you.


#6

When I input the login info, the launcher doesn’t do anything. Loading sign and back to input information.


#7

Good day,

I honestly do not know what might cause this error message.

Seeing how in your initial post you’ve said:

And in a subsequent one:

I’d have to assume that you might have tried to use the Whonix-Installer for Windows, though perhaps mixed up the guide for the Installer with the one for manual import via VBox which is why you attempted to import images as well as download a seperate Installer for VirtualBox.

At boot, there shouldn’t be a Login screen, unless you are running your Gateway in terminal only mode.

Seeing, how there seem to have been some issues from the start in regards to using Whonix-Installer but still trying to import the images seperatley, may I recommend uninstalling Whonix (Control Panel-> Programs and Features-> Whonix - Whonix for Windows-> Uninstall) and installing it again, this time by only executing Whonix-Installer.exe?

Have a nice day,

Ego


#8

Alright so attempt to download Whonix for Windows again or do I download using another method?


#9

Also, after the Whonix-Installer.exe has been downloaded, do I have to verify the installer once again?


#10

Good day,

Actually, if you were able to verify it via this guide: https://www.whonix.org/wiki/Installer/Verify_the_Installer_using_the_command_line there is no reason to download the installer again. You may use it a second time as well since the verification shows that the file is completely fine.

Have a nice day,

Ego


#11

Ignore this. Totally unrelated. Very minor. Detailed explanation and fixes already in the shared-folder-help package git history.


#12

Good to hear, and where can I find this shared folder help package?


#13

Great Ego, I re-installed the software, verified it once again, and when I ran it, it works. I do not know what caused the previous hiccup. Last but not least, I open the VM, click on Whonix Gateway, leave that alone, and then Whonix Workstation and work there correct?


#14

Good day,

Great to hear that it works. Yes, you are supposed to use the Workstation for “work”.

Have a nice day,

Ego


#15

Thanks for all your help Ego, I couldn’t have done it without you (or taken way longer) :grin:


#16
sudo apt-get update && sudo apt-get install shared-folder-help

(Would also be upgraded during a usual apt-get dist-upgrade.)