[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Cannot get user >Tor > VPN, still connected to Tor

Hello guys,

First of all, I am the biggest newbie, but I Am learning how to use Whonix. Recently, I have been trying to get VPN working through Tor. after running ‘sudo openvpn --config config.ovpn’ I get no errors and the last message reads ‘Initialization sequence completed’. But when I open tor browser, I see I am still using tor and my ip is not the one from vpn.
I read alot and came across something about removing all proxy settings, which I have no idea how to do. I tried to look into it and figure out how to do this but couldnt figure it out. Also i came across enabling TransPort instead of socksPort, which I am not sure how to do.
Please note I was using tor on windows and now i have learned about whonix and would like to use this instead of windows. Please be patient with me as I have very little knowledge in these matters.
Thank you for your help.
Here is the output after running openvpn.

root@host:/etc/openvpn# sudo openvpn --config config.ovpn
Thu Mar 12 13:20:51 2015 OpenVPN 2.2.1 i486-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] [eurephia] [MH] [PF_INET6] [IPv6 payload 20110424-2 (2.2RC2)] built on Dec 1 2014
Thu Mar 12 13:20:51 2015 NOTE: OpenVPN 2.1 requires ‘–script-security 2’ or higher to call user-defined scripts or executables
Thu Mar 12 13:20:51 2015 LZO compression initialized
Thu Mar 12 13:20:51 2015 Attempting to establish TCP connection with [AF_INET]87.118.127.176:1194 [nonblock]
Thu Mar 12 13:20:52 2015 TCP connection established with [AF_INET]87.118.127.176:1194
Thu Mar 12 13:20:52 2015 TCPv4_CLIENT link local: [undef]
Thu Mar 12 13:20:52 2015 TCPv4_CLIENT link remote: [AF_INET]87.118.127.176:1194
Thu Mar 12 13:21:05 2015 [example.com] Peer Connection Initiated with [AF_INET]87.118.127.176:1194
Thu Mar 12 13:21:08 2015 TUN/TAP device tap2 opened
Thu Mar 12 13:21:08 2015 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Thu Mar 12 13:21:08 2015 /sbin/ifconfig tap2 10.8.0.4 netmask 255.255.255.0 mtu 1500 broadcast 10.8.0.255
Thu Mar 12 13:21:08 2015 Initialization Sequence Completed

oh BTW I am doing all this in Whonix-workstation. ;D

Thu Mar 12 13:21:08 2015 Initialization Sequence Completed
That's a good sign.
I read alot and came across something about removing all proxy settings, which I have no idea how to do. I tried to look into it and figure out how to do this but couldnt figure it out.
For Tor Browser there are step by step instructions here: https://www.whonix.org/wiki/Tor_Browser#Change.2FRemove_Proxy_Settings
Also i came across enabling TransPort instead of socksPort, which I am not sure how to do.
See this page: https://www.whonix.org/wiki/Stream_Isolation

For uwt wrapped applications, see:

When those are configured by proxy settings, those can be undone by going to the application’s proxy settings.

Hello Patrick
Thank you for you reply.

I did those and still get the same result. Here is what I did (correct me if I have done things wrong):

all done in Whonix-workstation…

Ok first for changing the proxy settings, I went to /home/user/tor-browser_en-US/start-tor-browser and added ‘export TOR_TRANSPROXY=1’ just under ‘#!/bin/bash’. In the link you provided it says to add that line right below ‘#!/bin/sh’ but i couldnt find ‘sh’ just ‘bash’. So that is that.

I also added ‘export TOR_TRANSPROXY=1’ to /etc/environment. It was an empty file when i opened it with Kwrite and just added it.

Next I went to ‘/etc/uwt.d/30_uwt_default’ and just disabled uwt wrapper globally by changing the ‘“1”’ to’“0”’. I am not sure if that is the correct way… This is how it looks like now in the file:

Enable or disable all uwt stream isolation wrappers globally.

uwtwrapper_global=“0”

End quote.

I did reboot of both VMs.

After the above I ran terminal to go the folder openvpn and ran ‘sudo openvpn --config config.ovpn’ and no errors come up and it says ‘initialization sequence completed’. However, when open tor browser, and type check.torproject.org it still says you are connected to tor and it gives a different ip that the vpn one. I ran check2ip.com and it give a different ip.

What should I do?

Thank you for your patience and I hope you can help me.

The environment variable settings method works for me. Just now checked again.

Check Tor Button preferences, see if it’s set to transparent torification.

sorry, thats what i did not do.
Where do i find the tor button preferences?
when i click on the Tor network setting in the tor browser, i get a message:
‘Unable to retrieve Tor settings.
Please ensure that Tor is running.’

So please show where is tor button preferences in this workstation.
thanks Patrick.

From https://www.whonix.org/wiki/Tor_Browser#Change.2FRemove_Proxy_Settings:

[u]Preferences[/u]
[u][b]Forget[/b] about Tor Button's -> Open Network Settings.[/u] See footnote, if you want to know why.[32]

Really sorry Patrick for asking such noob question … I dont know where to find the torbutton. if you could point it to me…

I click on the Open menu from tor browser and select ‘preferences’ from there… then I click on Advanced > Networking and under the connection i click ‘settings…’ and there ‘no proxy’ is selected. But I think that is not the torbutton preferences…
so please if you can help me find the torbutton …

Is there a way in the terminal to access the torbutton preferences and implement transparent torification ?

thanks for being patient with me.

lol … i like you reply…

Ok i knew it might be that… but once i click on that there is no ‘preferences’ tab. The options that i see are:

‘New Identity
New tor circuit for this Site
Privacy security settings…
Tor network settings…
Check for Tor browser Update…’

When I click on ‘Tor Network Settings…’ I get this message:

‘Unable to retrieve Tor settings.
Please ensure that Tor is running.’

So dont know where to find ‘preferences’.

Thanks Patrick…

Looks like the menu has been removed in the latest version by The Tor Project.

Get the stable rather than alpha version:

Then follow the newly added screenshots:

Asked on IRC. It’s true.
References:

As far as the current alpha version is concerned…

Quote, IRC:

GeKo: can it be somehow manually invoked still? Patrick: no, but all preferences are still there. just the UI is not visible anymore

https://trac.torproject.org/projects/tor/ticket/11191#comment:6

Users who need to set proxy settings can do this via the Firefox settings, which still work just fine.

Patrick thank you for all this.
And i appreciate that you modified the steps with screen shots.

Ok i got the new stable version of Tor so now I have preferences. And I set the preferences to Transparent torification.
And I ran ‘sudo openvpn --config config.ovpn’ from the /etc/openvpn in terminal. All went well again with no errors and the end saying ‘initialization sequence completed’. HOwever, when i fired tor browser and check.torproject.org showed that i was still connected to tor.

I confirmed that I included in the new start-tor-browser this line :
#!/bin/bash
export TOR_TRANSPROXY=1

and i confirmed that the /etc/uwt.d/30_uwt_default had this line included ‘uwtwrapper_global=“0”’.

And i checked /etc/environment to have this line ‘TOR_TRANSPROXY=1’.

So i have all this done. And i restarted the gateway and the workstation, I still am connected to tor after running openvpn.

What do you think is happening here… and I missing something or do something incorrectly… ?

I much appreciate the fact that you are taking time to help me …

Output from openvpn:

user@host:/etc/openvpn$ sudo openvpn --config config.ovpn
[sudo] password for user:
Sun Mar 15 12:24:37 2015 OpenVPN 2.2.1 i486-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] [eurephia] [MH] [PF_INET6] [IPv6 payload 20110424-2 (2.2RC2)] built on Dec 1 2014
Sun Mar 15 12:24:37 2015 NOTE: OpenVPN 2.1 requires ‘–script-security 2’ or higher to call user-defined scripts or executables
Sun Mar 15 12:24:37 2015 LZO compression initialized
Sun Mar 15 12:24:37 2015 Attempting to establish TCP connection with [AF_INET]87.118.127.176:1194 [nonblock]
Sun Mar 15 12:24:38 2015 TCP connection established with [AF_INET]87.118.127.176:1194
Sun Mar 15 12:24:38 2015 TCPv4_CLIENT link local: [undef]
Sun Mar 15 12:24:38 2015 TCPv4_CLIENT link remote: [AF_INET]87.118.127.176:1194
Sun Mar 15 12:24:52 2015 [example.com] Peer Connection Initiated with [AF_INET]87.118.127.176:1194
Sun Mar 15 12:24:55 2015 TUN/TAP device tap0 opened
Sun Mar 15 12:24:55 2015 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Sun Mar 15 12:24:55 2015 /sbin/ifconfig tap0 10.8.0.3 netmask 255.255.255.0 mtu 1500 broadcast 10.8.0.255
Sun Mar 15 12:24:55 2015 Initialization Sequence Completed

It has nothing to do with uwt.

Then I have no idea.

SOrry … I made a new account, as I forgot my pass. I am newbie101.

So I should give up on setting up VPN in whonix? Do you have any suggestions what should I do ? All I Want is to set up vpn through tor…

Thanks Patrick.

I have no more suggestions. Besides less realistic ones:

  • find a linux user group
  • become programmer
  • pay someone

Please don’t post off-topic in other threads.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]