[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Cannot get the qcow2 to boot on PureOS


#1

Hey there,
after reading the tutorial and succesfully importing the qcow2 image and importing the XMLs it just doesn’t boot. It just says, that the disk is not bootable. The path to the image is correct (checked the path, where the XML imports the image and the configuration page in virt-manager) and I think the permissions as well (the image is in the default path, tried another path where I do have several working VMs but to no avail)
I even downloaded and extracted it several times to check if the image is corrupt.

Running virt-manager 2.0 and libvirt 5.0.0-1, the XML configuration is untouched, so no (obvious) human error.

Thanks in advance!


#2

Try creating a plain Debian VM and report if you are seeing the sam error please.


#3

Ok, setting up Debian Stretch with virtio network and disk works flawlessly.
How can I debug this behavior? It seems, that the disk is recognized but the bootloader on the image is somehow not working…

EDIT: Directory, permissions are the same.


#4

Are there any error messages that you see? Please post them so I can use it to search.


#5

Really thank you for your help :slight_smile:
Tried two different versions:

  • Whonix-Gateway-XFCE-14.0.0.9.9
  • Whonix-Gateway-XFCE-14.0.1.1.7

All I get is:
Boot failed: no bootable disk
No bootable device
Does the Whonix-Gateway use a setting, which needs non-free software? Because PureOS doesn’t have any non-free binaries installed…


#6

Absolutely not.

At this point I recommend moving to Debian stable instead which you can run without non-free firmware blobs if your hardware is designed to work without it.

The problem with downstream distros is they sometimes base off buggy versions of testing and/or they make obscure changes that mess things up but aren’t readily visible.


#7

Got it. You HAVE to untar it. I’ve used the nautilus unzip option and it seems, that this corrupts the image somehow. Pretty weird, so for the next time: Stick to the documentation.


#8

Yes documentation knows best :^)