Cannot find qcow2 image file


Hi there. I’m new to Whonix and have studied lots of related materials about it. However, I still have encountered a problem when I try to use it on my laptop computer. What I’m trying to do is to run Whonix ( on my host system, Linux Mint 18, with QEMU/KVM. And I followed the tutorial (https://www.whonix.org/wiki/KVM), did exactly everything it instructs without any error message. But when I try to boot Whonix-Gateway from virt-manager, an error occurs with the this message :
Cannot access storage file ‘/var/lib/libvirt/images/Whonix-Gateway.qcow2’ (as uid:124, gid:133): No such file or directory
I’ve checked out /var/lib/libvirt/images, it is really an empty directory. I don’t understand why there’s no image file since I have not tried to move it to anywhere. Can anyone give me clue about what is going on and how can I fix it ? Thanks a lot.


Hi. Thanks for trying Whonix KVM.

You must move the unarchived qcow2 image into the libvirt images folder. Make sure you do this step as root because its a privileged directory.


I get the same error.

Can you try importing the files with the GUI and tell us what the results are? (Use the qcow2 files as disk image)

I tried it and then Tor doesn’t work in Gateway.


How do we do this? The files that were extracted are actually in the same folder where the xz files are. I don’t understand what you mean by moving to the image folder.


Assuming you extracted the images in the home folder please follow the steps here: https://www.whonix.org/wiki/KVM#Moving_Whonix_Image_Files

to transfer them into the libvirt directory so KVM can boot from them.