[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Cannot boot whonix gateway

I’ve tried to build Whonix 15 physical isolated GW on amd64 hardware, debian buster installed.

Build script I’ve used:

sudo ./whonix_build --flavor whonix-gateway-xfce --target raw --build

After that I’ve successfully got a raw image (100+ gb size) and had no idea what exactly to do with it (unfortunately, some building aspects described in Whonix documentation are really unobivous for an amateur user like me), so I went for another script:

sudo ./whonix_build --flavor whonix-gateway-xfce --target root --build

After successful build I’ve rebooted PC and got 2 boot options: Whonix GNU/Linux and Whonix Live-mode GNU/Linux.

Trying to boot Whonix GNU/Linux:

/scripts/init-top/udev: line 26: udevadm: not found
/scripts/local-premount/resume: line 287: udevadm: not found
Gave up waiting for suspend/resume device
Gave up waiting for root file system device

ALERT! UUID=9057d3b6-abb0-4c99-b189-47f63c08cc42 does not exist. Dropping to a shell!

As for Whonix Live-mode GNU/Linux, the result is pretty same:

BOOT FAILED!

Can not mount /dev/disk/by-uuid/9057d3b6-abb0-4c99-b189-47f63c08cc42 on run/live/rootfs/filesystem

What’s wrong with it?

Looks like it doesn’t find the root filesystem. I guess, either because it’s not there or because it doesn’t look for the correct UUID.
Normally you get dropped to a shell. You can try to run “blkid” and look for the identifier and for the device name, or when you are in the grub menu press “e” and then go to the line with “/dev/disk/ …” and change this to the disk name (like /dev/sda1). There is some build option to decrease the disk size (need to look it up).
You can burn the image similar to the rpi ones to a disk (not neccessarily an SD card) see here: https://www.whonix.org/wiki/Dev/Build_Documentation/Physical_Isolation
For testing you can also use the raw image with KVM.
Even more easy maybe: Convert the official qcow2 gateway image to RAW and burn it to a disk. There are some related threads around here. Be careful when burning so you don’t overwrite something important.

2 Likes

Thank you, it worked.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]