[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Cannot add SOCKS proxy to Tor Browser

I want: ISP -> Tor -> Proxy -> Site.
Reason: to bypass Tor exit nodes block by destination website.
Why in Tor Browser not in Firefox: to have the same fingerprint as in TB and to get rid of Firefox built-in malware.

Hello. I’d like to set up SOCKS(4/5) proxy in Tor Browser on Whonix Workstation. I followed the instruction described in support but after I perform the actions described in wiki, connections are closed though in Firefox browser on top of Workstation adding SOCKS proxies works well. I think that something inside Whonix Tor Browser configuration prevents from connection to SOCKS proxies.

I did the following inside Tor Browser’s about:config:
extensions.torbutton.use_nontor_proxytrue
network.proxy.no_proxies_on0
network.proxy.socksIP of proxy server
network.proxy.socks_portPort number of proxy server

But that doesn’t work! Help please!

No changes from the Whonix side related to that in a long time.

Whonix Tor Browser configuration is by design kept minimal to prevent such doubts and mystery, see Whonix ™ Tor Browser Differences.

The grand total of changes essentially boils down to these Environmental Variable Adjustments.

I recommend Generic Bug Reproduction as follows:
Use Tor Browser outside of Whonix (in Debian bullseye) and re-configure it to use only a proxy. Only once that is known to work, try inside Whonix-Workstaiton.


For reference:

Finally, I’ve found the solution how to turn on SOCKS proxy on Tor Browser in Whonix Workstation. I made the following steps:

  1. Reinstalled fresh Tor Browser using Tor Browser Downloader (by Whonix)
  2. Started TB, went to about:config and switched network.dns.disabled (enable DNS resolving) option to false
  3. Then, I switched extensions.torbutton.use_nontor_proxy (allow Tor Browser to use non-Tor proxies) to true. Browser was restarted automatically after switching that option
  4. Then, in about:config I set network.proxy.no_proxies_on option value 0 (told TB that I want to use proxy)
  5. And finally, set up SOCKS proxy settings:
    network.proxy.socksIP of proxy server
    network.proxy.socks_portPort number
    network.proxy.socks_remote_dnsfalse (if your proxy server doesn’t support resolving DNS through proxy. In this case, DNS will go through Tor exit nodes thanks to Whonix)
    network.proxy.socks_version4/5 (Version of your proxy server)

After that, everything worked well!

1 Like

Thank you.

Created for it:

I don’t know why, but socks proxies still work bad with Tor Browser. Connections are slower, sometimes disappears. SOCKS proxies works better with Firefox ESR on top of Whonix Workstation. May be it depends on proxy, may be not. So, I don’t know why proxies work better with Firefox ESR and worse with TBB.

So, there are generally two approaches how to make ISP -> Tor -> Proxy -> Site work well.

  1. Modifying Whonix’s TBB settings in order to make TBB on top of ws work well with socks proxies.
  2. Use Firefox ESR and edit about:config settings as much as possible in order to make Firefox ESR fingerprint similar to Tor Browser. Huge job should be done in that case.

Could be, sounds unspecific to Whonix.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]