Can’t enable USB Drive in VirtualBox – troubleshooting help needed

I’ve followed Whonix documentation but haven’t been able to get USB drives enabled. When I connect a USB drive to my PC running Ubuntu, and then run VirtualBox/Whonix, the drive is not found by VB/Whonix (USB status icon says “no USB devices connected).

My setup:
-Ubuntu 14.04 on PC laptop (single OS)
-newest versions of VirtualBox, Whonix Gateway and Whonix Workstation – Whonix and VirtualBox – all running fine.
-USB 2.0 drive I’m testing is FAT32

Things I’ve done:
-successful install of VirtualBox 5.0.8 Extension Pack on Ubuntu for USB support (is this the only install I need?)
-in VirtualBox Manager I used the Settings in both Gateway and Workstation to enable automatic or manual USB mounting. Selected the USB 2.0 option. Also used the USB device filter settings to add a generic filter which is supposed to mount any type of connected USB drive.
-in Whonix Gateway and Workstation – System Settings- Removable Devices I checked the boxes for all USB mounting settings.

VirtualBox.Org USB Troubleshooting Instructions (Chapter 12.8.7)
-I’m not sure which of these instructions may apply to my setup.
-as per instructions, tried editing the fstab file as indicated to add a reference to vboxusers group, because I couldn’t find any reference to a “USB” group. After the fstab edit the USB drive still didn’t connect (this caused a “/proc/bus/usb” error message on boot, so I removed the edit to correct that).

Any USB troubleshooting advice would be appreciated

Mounting (CD / DVD) Devices ?

Thanks for reply Partrick, but I’m a bit lost.

My device, in this case a USB drive plugged into the host, doesn’t seem to be found at all in Workstation, so I’m not sure how I can attempt to mount it manually. There is no sign of a USB in the Removable Media menu. So, I’m not sure if this is a case of the “auto mounter” vs. manual mount- it seems there’s something more basic wrong? Am I correct I should be able to “see” the unmounted USB in Workstation to start the process of manually mounting it?

I tried the instructions in forum topic 1526. I installed Gparted on Workstation, but again no sign of the USB in Gparted.

So, I’m stuck at the moment :frowning:

Wrong link to documentation. Try this:

Success mounting my USB on Whonix Workstation :slight_smile: Thanks Patrick for offering your assistance.

My solution:
-I found a forum post suggesting the command sudo usermod -aG vboxusers . This seemed to be the key to a solution. When I ran this line I saw Whonix finally detected my USB.
-I followed other instructions on using Gparted to find the USB partition and then did manual commands to mount the drive. Gparted was tricky because the USB partition wasn’t visible in the default view. I had to use the “Gparted” option on the menu bar, and then I could see the USB partition.

So now the USB is mounted and I can see the files in Whonix Workstation Dolphin, but now I get “Access Denied” message when I try to copy files to the USB. It seems I don’t have write access. I found a forum post and tried running a chmod command to give write permissions, but it didn’t work. It said “operation not permitted” for each file on the drive and the folder location. Any suggestions would be appreciated :slight_smile:

Run sudo usermod -aG vboxusers <my username> where? Can contribute/edit the documentation please?

This really sounds like the auto mouter issue:
Mounting (CD / DVD) Devices

Here are more details about my solution where Whonix Workstation on Virtualbox would not even detect a USB drive, so I had no opportunity to mount it manually (since we all know auto mount doesn’t work well).

  • first, I ran this command line on my host OS Ubuntu 14.04: sudo usermod -aG vboxusers
  • then when I started Whonix I saw the USB was finally detected.
  • then I followed the instructions on the post below - use the terminal to create new folders to mount the drive, use Gparted to know the exact location of the USB, then use terminal again to run the manual mount commands.


  • one small tricky part of Gparted is you must use the “Gparted” selection on the menu bar to toggle from the default view of the Workstation partitions to find the USB drive partition.
  • since only one OS at a time can control the USB drive, when you run your host, Gateway, and Workstation at the same time, you will see control of the USB will switch back and forth between the OSs when you connect or eject the USB.

anyone please improve https://www.whonix.org/wiki/File_Transfer#Adding_USB_device_to_VirtualBox

Since mount a USB drive in Workstation I haven’t figured out how to grant “write” permission on the drive. I’ve tried all kinds of chmod, chown, chgrp commands. I researched a solution to install the utility “hdparm”, then ran the command hdparm -r0 /dev/sdb , but that didn’t work. The permissions didn’t change, and the USB is still read-only.

Any suggestions for a solution would be appreciated.

Install Debian jessie with KDE in a VM. Try if it works there. Just now wrote the following. Try as per:

I reviewed the following resources:
virtualbox - manual/UserManual.html#usb-support"
forums = can-t-enable-usb-drive-in-virtualbox-troubleshooting-help-needed/1563

And I still cannot get the USB to be recognized on the guest computer.

I am using windows 10 on host computer.
In settings, I enabled USB controller (2.0), added a filter for the USB device that I wanted to use and tried every setting related to remote (yes, no, any).
In the VM, I also checked the box for mount removable drives/media when hot-plugged and inserted.

Am I missing something? Any help would be appreciated. Thanks!

for now having trouble with vbox, until we come either with a fix or manually user adding guest-additions this mostly wont work.

if its possible , try install guest-additions-iso from vbox menu (search for how to install vbox guest-additions) then report back here if you can.

Small Note: Using windows as a host worsen your anonymity:

  1. make it work in a non-Whonix, Debian based VM first
  2. try the same inside Whonix

Please read the chapter Whonix ™ is based on Debian. Means, you can change your search terms from “How to get USB in Whonix-Workstation ™?” to “How to get USB in VirtualBox?”. See also Free Support Principle.

https://www.whonix.org/wiki/File_Transfer#Adding_USB_device_to_VirtualBox has a footnotes saying:

Does ‘’‘not’’’ require VirtualBox Guest Additions.

Made that a non-footnote now.

When following documentation as updated recently, there is no need for this.

https://www.whonix.org/wiki/VirtualBox/Troubleshooting#General_VirtualBox_Troubleshooting_Steps says actually for now:

Do not use VirtualBox guest additions from ISO.
Installation of VirtualBox guest additions from ISO might also cause issues.

Will be updated should that change on that wiki page.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]