[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Bridges OBSF4 problem

I have configured bridges and restarted Tor. Everything works like a charm but when i open arm in Gateway I get a notifications ( I deleted time logs ):

[WARN] Proxy Client: unable to connect to //////////Deleted/////////////////////////// (“server rejected connection”)
[ARM_NOTICE] Unable to prepopulate bandwidth information (insufficient uptime)
[ARM_WARN] The torrc differs from what tor’s using. You can issue a sighup to reload the torrc values by pressing x.

  • configuration values are missing from the torrc: HiddenServiceStatistics, RunAsDaemon
    [ARM_NOTICE] Tor is preventing system utilities like netstat and lsof from working. This means that arm can’t provide you with conn-
    ection information. You can change this by adding ‘DisableDebuggerAttachment 0’ to your torrc and restarting tor. For more information see… https://trac.torproject.org/3313
    [ARM_NOTICE] Arm is currently running with root permissions. This is not a good idea, and will still work perfectly well if it’s run
    with the same user as Tor (ie, starting with “sudo -u debian-tor arm”).
    [ARM_NOTICE] No armrc loaded, using defaults. You can customize arm by placing a configuration file at ‘/root/.arm/armrc’ (see the
    armrc.sample for its options).

And when I check my connections I see that the entry node has the same hexadecimal code as the first one of the three bridges I got from here and written down in /etc/tor/torrc, but different IP.

When in arm I press x to recover values from torrc I get loads of such notifications ( i deleted ip address ):
[WARN] Proxy Client: unable to connect to >>IP address<<:9443 (“server rejected connection”)
│ 13:32:44 [NOTICE] You configured a non-loopback address ‘>>IP address<:9040’ for TransPort. This allows everybody on your local network to
│ use your machine as a proxy. Make sure this is what you wanted. [1 duplicate hidden]
│ 13:32:44 [NOTICE] You configured a non-loopback address ‘>>IP address<:5300’ for DNSPort. This allows everybody on your local network to
│ use your machine as a proxy. Make sure this is what you wanted. [1 duplicate hidden]
│ 13:32:44 [NOTICE] You configured a non-loopback address ‘1>>IP address<<:9189’ for SocksPort. This allows everybody on your local network to
│ use your machine as a proxy. Make sure this is what you wanted. [1 duplicate hidden]

And my /etc/ter/torrc file looks like this ( I deleted bidges IP and other data due to obvious reasons ):

This file is part of Whonix

Copyright © 2012 - 2013 adrelanos

See the file COPYING for copying conditions.

Use this file for your user customizations.

Please see /etc/tor/torrc.examples for help, options, comments etc.

Anything here will override Whonix’s own Tor config customizations in

/usr/share/tor/tor-service-defaults-torrc

Enable Tor through whonixsetup or manually uncomment “DisableNetwork 0” by

removing the # in front of it.

DisableNetwork 0
UseBridges 1
ClientTransportPlugin obfs2,obfs3 exec /usr/bin/obfsproxy managed
ClientTransportPlugin obfs4 exec /usr/bin/obfs4proxy managed
ClientTransportPlugin fte exec /usr/bin/fteproxy --managed
bridge obfs4 //////////Deleted///////////////////////////
bridge obfs4 //////////Deleted///////////////////////////
bridge obfs4 //////////Deleted///////////////////////////

Is everything OK or did I srew up?


Most log messages you see in arm are non-issues. See:
https://www.whonix.org/wiki/Tor_Controller#Arm_FAQ

Not sure but perhaps this is related:
https://www.whonix.org/wiki/FAQ#Am_I_compromised.3F


Are you living in a censored area? Does Tor Browser Bundle outside of Whonix work for you?

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]