[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Bootstraping connection stops at 5% in vmware workstation

Hi,

I have a problem with connection in vmware workstation. I convert vm in virtualbox to use it in vmware. After that I cannot make a connection in vmware. All others vm in vmware working fine. Clock is fine. I check the firewall. Tor browser is working fine on host machine. I replace virtuabox guest addition with open vm tools. Nothing helps. Whonix everytime shows me “no route to host”. Anybody knows what should I change in vmware settings or adapter settings?

I know the documentation. I spent a lot of time trying fix that. If anyone know the solution please help.

I have the same issue with vmware workstation. I have tried just about everything, even routing it through opnsense via custom lan segment. Have tried NAT, custom vmnet, bridged. I am getting the same error in my tor logs (no route to host). Works perfectly on virtual box. Yes I know I should be using virtual box over vmware but my 12+ VMs are on vmware and i’m trying to learn how to route stuff and learn general networking with OPNsense (fork of pfsense).

Also i’m on Windows 10 if that helps. Any help would be greatly appreciated! Also thanks for everything you do Patrick, you are a true hero!

Thank you!

Actually to the contrary. Developers using Linux hosts (Debian, Kicksecure, Qubes OS). Therefore low familiarity with Windows. See also:

I’ve been planning on switching for some time, but I think you just gave me the courage to finally make the switch to strictly use Linux and open source software. I’m sick of Microsoft’s crap and I use Linux every day both in VMs at home and at work so the switch shouldn’t be too bad. Proprietary software just seems to be getting worse and worse every year.

Anyways I just wanted to update this thread by saying I fixed this by setting a static IP in whonix gateway that was within my subnet range. I didn’t try using vmware’s dhcp server, I just added a static IP to my (virtual) router’s software (OPNsense). If you’re going to use VMWare’s Virtual Network Editor try disabling the DHCP server and again setting an IP within the set subnet range. You can change these network settings here:
/etc/network/interfaces.d/30_non-qubes-whonix
Hope this helps!

I was actually going to give a bit of a spiel for switching when I first read this, but seeing as though you were so invested in vm ware I didn’t think that it would be helpful. I applaud your decision (not that you need my applause…but you get what I mean).

I made the switch about four years ago and couldn’t be happier. Using kvm or virtualbox, you won’t look back. Good one!

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]