[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Boot failed: not a bootable disk

Hi,
I am able to run Whonix Gateway and Whonix Workstation shown in virtual machine manager but when I click on Open, I get “Boot failed: not a bootable disk. No bootable device” error.

Installation details:

  1. I have installed Whonix on Debian Stretch and verified the Whonix image.
  2. I have decompressed the libvirt.xz file and then completed the ‘Importing Whonix VM Templates’ step.
  3. I have also run the following command to shorten the image files (Workstation and Gateway):

qemu-img convert -f raw -O qcow2 Whonix-Workstation-XFCE-15.0.0.0.9.qcow2 Whonix-Workstation.qcow2

(again one more time for Gateway.qcow2 image)

  1. After that I have used mv command instead of cp --sparse command to move the images to `/var/lib/libvirt/images

I am including a link (I hope this is allowed) to the gateway xml file incase there is any change needed to solve this error.
Whonix-Gateway-XFCE-15.0.0.0.9.xml
Link[Delete space before .com]:- writeurl. com/text/vhov6z77cg0ttqzkhqis/l3qm1ohty9b33cpuhwqf

Note: There is already a similar topic on this forum but he/she is trying to load libvirt and xml files in that topic.

Have you tried using them before reconverting? This is unnecessary because the image files are sparse and don’t actually occupy 100GB each but may grow to that point.

Using the original qcow2 files solved the problem. The qcow2 occupied about 100GB each after extracting from the Whonix .xz file but did not occupy full 100GB space after copying via cp --sparse command.

Thanks a lot HulaHoop!

1 Like