Blocked at "git status" step...


Hi all,
i’ve recently decided to install Whonix Gateway on an old computer (2001’s i think). I must admit i found some difficulties as i’m not familiar with command lines but this time i’m definitely blocked.
:ballot_box_with_check: downloaded Debian “light version” with non free firmwares (in order to directly configure my wifi antenna)
:ballot_box_with_check: transfered Debian on a bootable usb key
:ballot_box_with_check: installed Debian from my key to the computer
:ballot_box_with_check: updated Debian
:ballot_box_with_check: installed, sudo, git, curl and checked signing keys
:ballot_box_with_check: got the source code, verified it with OpenPGP

Problem appears at “Clean up and Sanitize” section :
git checkout answers HEAD is now at ec26388
git status answers HEAD detached at

I tried once to build Whonix even with that messages but i received a lot of errors messages.


The ‘git status’ looks alright and is most likely a non-issue.


All was ok but it looks like progression shows some errors.
Really don’t know how to post them here : TRUE errors, BASH COMMAND etc.
examples :
ERROR in ./helps_steps/whonix_build_one
ERROR in ./whonix_build
INFO: now exiting from ./whonix_build (because error was detected, see above)

There is any way to delete entire installation by deleting Whonix FOLDER and start from debian clean installation or should i start from begining (again) ?

After reboot, Whonix Gateway looks to work but as my usb mouse wasn’t recognized… I don’t know.


You need to post the build log. Sometimes also only the error is enough.


Doesn’t mean much but errors during build matter.


Hi Patrick, thanks for your help. I decided to reinstall all ; with same errors - but this time saving steps in a log file as it is said in documentation.
I tried to build a Whonix without interface ( gui --none).
After a reboot, logged with my username and password, those message appears :
“Starting Whonix Repository Tool…
ERROR: --repository must be either stable, testers or developers.
Something went wrong. Please report this bug!
BASH_COMMAND: whonix_repository
[ERROR] [whonixsetup] ret: 1 | BASH_COMMAND: sudo whonixsetup --cli | Please report this bug!”

How can i find phyiso log and post it here ?



Isn’t a build error. Is a terminal-only related known bug. Has been discussed in the forums.