[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

black screen on gateway etc.

Hello
i installed whonix on march and everything went great,
so i was probably on VB 6.1.4 and whatever whonix version that was at that time.
since then I’ve updated VB a few times and if i recall correctly 6.1.6 and 6.1.8 worked fine.
not sure where and why every thing started braking;was it the new Distro upgrade or VB but i had things like a black screen on the gateway and the workstation could not load at all after the boot screen(grub menu?).
any how after trying a few VB box versions with no solution,i deleted the VMs,uninstalled VB,rebooted the windows PC and installed the recommended 6.1.6 VB and downloaded the latest whonix ver.
now what i get is a black screen on the gateway but it’s still functional and the the workstation is blue but without the mouse figure.but still works.

not sure what went wrong,but by browsing i saw it was common on many distros and had many solutions and i also checked the whonix wiki about the black screen but it didn’t work for me.
fortunately now every thing seems to work but i got sometimes some hick-ups like the gateway is black and not functional(no taskbar) and other weird stuff.

i just made clones of both the gateway and WS;
the gateway desktop is black but functional but the workstation is just black,can do nothing on it,had to shutdown through VB.

1 Like

You seem to be describing more than one problem. For instance, the GW background is now black to help remind the user which VM they are using. It helps prevent errors if a user mistakes one for the other.

Any loss of functionality would be a different problem. Issues with a recent Windows 10 update have been reported here in the forum. Do some searching for recent posts. It will help you to be more specific. :slight_smile:

1 Like

@Patrick

i tried all different Virtual Graphics Controller with no avail.
i have no idea how to do the nomodeset thing and what does it means in general and for my personal experience.
i updated the Guest additions,hope this fixes it.

@81a989

i didn’t know they made the gateway desktop black now to avoid confusion,
i tried looking a bit in the release notes but couldn’t find it.

and about my issue,it’s quit specific(i think);some time when launching the VM’s(mostly the workstation?)it either goes to the regular blue background and all is fine,or a black background but i still have a functioning task bar and can use this VM,or it’s a black background with nothing,like if the vm didn’t manage to load.
right now with VB 6.1.6 and the latest whonix release a reboot usually solve this,but previously with other VB ver.it just wouldn’t load.

Have you tried checking the VM logs in the host? That might help.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]