Back to KVM: questions on default resolution, grub-live and clipboard sharing in

So here I am again trying to switch from VirtualBox to KVM/virt-manager full-time…

I’ve just downloaded the libvirt images, last available version ( Just a few points I’d like to discuss/find solutions for.

First, I had to adapt the display in order to have a normal resolution: Whisker Menu → display → changed Resolution to 1920x1080. Works great, and survives reboot!

Suggestion: shouldn’t this resolution be set as default in the libvirt images? It’s hard-coded in this file: .config/xfce4/xfconf/xfce-perchannel-xml/displays.xml on XFCE4, and so can be simply added during the build phase:

  <?xml version="1.0" encoding="UTF-8"?>
    <channel name="displays" version="1.0">
      <property name="Default" type="empty">
        <property name="Virtual-0" type="string" value="Virtual-0">
          <property name="Active" type="bool" value="true"/>
          <property name="Resolution" type="string" value="1920x1080"/>
          <property name="RefreshRate" type="double" value="59.962844"/>
          <property name="Rotation" type="int" value="0"/>
          <property name="Reflection" type="string" value="0"/>
          <property name="Primary" type="bool" value="true"/>
          <property name="Position" type="empty">
            <property name="X" type="int" value="0"/>
            <property name="Y" type="int" value="0"/>

Otherwise first users boot a machine with a very poor 1024x768 resolution and won’t know how to change this… Quite a putting off experience!

2. Clipboard copy not working?

Although spice-vdagent is installed and running, I am unable to copy-paste text from the vm to the host and vice-versa:

user@host:~$ ps auxf | grep -i vdagent | grep -v grep
root       541  0.0  0.1  35140  2656 ?        Ss   13:52   0:00 /usr/sbin/spice-vdagentd
user       929  0.0  0.3 176320  6976 ?        Ss   13:52   0:00 /usr/bin/spice-vdagent

Anything I am missing to make this work? Or is it expected behavior? On other, non-whonix (debian) KVM VMs that I have been playing with lately, the installation of spice-vdagent package was enough to make it work out of the box. Is it different with Whonix?

3. grub-live is not installed, so whonix-live is not available by default
Again, this may be expected behavior, but I thought that since December it would be installed by default on all Whonix images (see http://forums.dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion/t/installing-whonix-live-mode-in-all-distributed-images/6467/10).

Is it not the case? The genmon applet is working btw…

user@host:~$ sudo apt install grub-live
[sudo] password for user:         
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  live-boot live-boot-doc live-boot-initramfs-tools live-config-systemd
  live-tools rsync uuid-runtime
Suggested packages:
  cryptsetup curlftpfs httpfs2 debian-installer-launcher eject openssh-client
The following NEW packages will be installed:
  grub-live live-boot live-boot-doc live-boot-initramfs-tools
  live-config-systemd live-tools rsync uuid-runtime
0 upgraded, 8 newly installed, 0 to remove and 2 not upgraded.
Need to get 684 kB of archives.
After this operation, 1,306 kB of additional disk space will be used.
Do you want to continue? [Y/n]
1 Like

Good to hear :slight_smile:

Awesome then I’ll document it after experimenting.

@Patrick what do you think? Is this a good solution that can be cleanly added and applies to all users?

That is a conscious decision by me to avoid accidentally cross pasting info between non anonymous VMs and Whonix. It saved me many times. Also keep in mind a malicious guest will be able to read the clipboard if enabled.

I assume you know what you’re doing so to enable, edit the workstation xml and scroll down to the spice section and remove the restriction.

Patrick mentioned that will change by Whonix 15.

Thanks for your feedback @onion_knight

1 Like

Could you test this please? @Algernon

Understood. Is it documented in the wiki?

OK. But I think it’s now default in the VirtualBox images? Anyway I’ve installed it myself in KVM :slight_smile:

You’re welcome!

The reasoning yes: how to reverse it no. Is this what you meant?

Yes, this is what I meant.

OK done.

Great, thanks!
@HulaHoop Any feedback regarding my proposal for the new default resolution? Did you experiment it?

1 Like

Unresolved. If no one volunteers doing this, not going to happen.

Yes I did. It works as advertised though that particular resolution does not match my screen. I think it would be hard to pick a good resolution that works for everybody. Anyway I will document it because it is that good.

Still needs a volunteer to test it in VirtualBox.

I think the problem does not exist in VirtualBox as guest additions take automatically care of seamless full resolution.