ARM Tor Browser Version lags behind

Unable to download tor browser in freshly built whonix for M2 Mac

Able to update repositories via cli but when I go to download the tor browser it fails with this error.

ERROR: Failed to download: Tor Browser Ports - Browse Files at
Possible reasons:

  • Internet connectivity issue.
  • The download server is down.
  • File size exceeded (endless data attack triggered).
  • Tor Browser Downloader (by Whonix developers) has been broken due to upstream changes.
    Tor Browser Essentials
    (Debugging information: curl_status_message: [22] - [HTTP page not retrieved. The requested url was not found or returned another error with the HTTP error code being 400 or above. This return code only appears if -f, --fail is used.])

Posting an error in the forums and being stuck waiting for others is awful. That’s not the spirit.

You can figure out how to debug this and fix this. I can teach you.

Any ideas how to start?

I already tried fixing it, I couldn’t figure it out… I checked the trouble shooting page and went through old forum posts. I am happy to learn, what can I do

I think it has something to do with this, with cloudflare.

I tried adding the skip connectivity check but it didn’t work.

Great! This time no failed connectivity check. The log looks different. See what you already posted.

The forum weirdly renders to a link but that doesn’t matter.

Use code tags.

What’s next? Try to open the link manually in the browser. What happens?

Then look closer at the link. Don’t consider it a huge gibberish long letter salad. There’s a structure.

Try to see the URL parts. These start with /. Modify the link.


And? Again…

Each time try to open the link.

What do you notice?

What’s next?

Okay, well 13.0.1 isn’t available on source forge yet? The latest is 13.0? Am I following correctly?


Now what is next?

Hint: There’s a solution in the manpage. Found that yet?

man torbrowser? In terminal? Do I need to direct the tor browser updater to download the older version?

Ended up wget the 13.0 to the .tb directory and it’s working now, I just need to update it to 13.0.1

man update-torbrowser

Found it even in the wiki.

Cool thanks for the lesson. Now that I have it downloaded manually will whonix gpg check and anon dist updater still be compatible

Since Tor Browser version information comes from Tor Project but ARM64 version comes from a different ARM64 Tor Browser Maintainer, I don’t have an idea how to fix that yet.

Maintaining two sets (TB amd64 stable, alpha + TB arm64 stable) hardcoded version number files would be extra maintenance effort.

Maybe separate code to parse the download page to get the latest version number.