[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Apt-Get Stuck???

I know you guys are tired of me and my problems by now… but im still learning so bare with me…

when i try to use “apt-get” anything its like the process gets hung up and will not complete… I was getting an error saying that another process was using it but now it just appears that it gets stuck. For instance…

when i try to install something it will attempt but stop at the part that says “xx space will be used to install” and ususally there it will ask yes or no…but now its not even giving that option… it just stops and doesnt respond to anything

I goggled around and thats all I came up with… none of the solutions seemed to work that were presented.

help?

Good day,

Would you mind telling us, what was the last thing the terminal put out?

Have a nice day,

Ego

Using terminal-only? -> More RAM. Increase to 196 MB.

I mentioned that up above. It just stops where the option to select yes or no to the install space amount would normally be.

This didnt work and I used far more than what you suggested…

but im using the terminal inside worksation. I increased the ram for workstation itself

Did you see my message?

Yes, but I have no idea.

No idea? Arent you one of the creators? Do you fully grasp the issue of what I am saying is taking place?

Yes, and because of this, I know that Whonix is not doing anything strange / special that would lead to such an issue.

Did you verify the vm images?

Does it work in gui mode?

Patrick, I’ve installed a completely fresh whonix because I assumes it would solve that issue but I am still experiencing the same exact problem. This is the output I get when trying to “kdesudo apt-get install pidgin”:

user@host:~$ kdesudo apt-get install pidgin
Reading package lists…
Building dependency tree…
Reading state information…
The following extra packages will be installed:
freepats gstreamer0.10-alsa gstreamer0.10-gconf gstreamer0.10-nice
gstreamer0.10-plugins-bad gstreamer0.10-plugins-base
gstreamer0.10-plugins-good gstreamer0.10-x libcdaudio1 libdirac-encoder0
libfarstream-0.1-0 libfftw3-double3 libgadu3 libgme0 libgssdp-1.0-3
libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-base0.10-0
libgstreamer0.10-0 libgtkspell0 libgupnp-1.0-4 libgupnp-igd-1.0-4
libmeanwhile1 libmimic0 libmms0 libnice10 libnspr4 libnss3 libofa0
libopenal-data libopenal1 libprotobuf-c1 libpurple-bin libpurple0 libslv2-9
libsoundtouch0 libspandsp2 libvo-aacenc0 libvo-amrwbenc0 libwildmidi-config
libwildmidi1 libzbar0 libzephyr4 pidgin-data python-dbus python-dbus-dev
Suggested packages:
frei0r-plugins libfftw3-bin libfftw3-dev gstreamer-codec-install
gnome-codec-install gstreamer0.10-tools libtcl8.6 libtk8.6 slv2-jack
python-dbus-doc python-dbus-dbg
Recommended packages:
gstreamer0.10-ffmpeg
The following NEW packages will be installed:
freepats gstreamer0.10-alsa gstreamer0.10-gconf gstreamer0.10-nice
gstreamer0.10-plugins-bad gstreamer0.10-plugins-base
gstreamer0.10-plugins-good gstreamer0.10-x libcdaudio1 libdirac-encoder0
libfarstream-0.1-0 libfftw3-double3 libgadu3 libgme0 libgssdp-1.0-3
libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-base0.10-0
libgstreamer0.10-0 libgtkspell0 libgupnp-1.0-4 libgupnp-igd-1.0-4
libmeanwhile1 libmimic0 libmms0 libnice10 libnspr4 libnss3 libofa0
libopenal-data libopenal1 libprotobuf-c1 libpurple-bin libpurple0 libslv2-9
libsoundtouch0 libspandsp2 libvo-aacenc0 libvo-amrwbenc0 libwildmidi-config
libwildmidi1 libzbar0 libzephyr4 pidgin pidgin-data python-dbus
python-dbus-dev
0 upgraded, 46 newly installed, 0 to remove and 0 not upgraded.
Need to get 50.8 MB of archives.
After this operation, 107 MB of additional disk space will be used.


This is where normally you would answer yes or no, but there is no option, and when I attempt to close out the terminal at this point, its tells me that “the process kdesudo is still running would I still like to close”

Can you shine some light on this issue, or anyone?

As I mentioned before I am using terminal inside workstation and I have allotted a ton of ram to Workstation as well. This is really frusterating guys.

Thanks

Just a guess, but since apt-get isn’t a GUI application: have you tried using just sudo instead of kdesudo?

1 Like

Funny, But thanks. This worked. Oddly I was taught awhile back to use kdesudo for everything.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]