Apparmor-profile-pidgin crashing when trying to message


I am running latest 9.2 and have installed pidgin (sudo apt-get install pidgin) with OTR and apparmor-profile-pidgin

After I install the profile and run pidgin add account, I get various apparmor messages all about Operation: file_mmap errors, one example below:

profile: /usr/bin/pidgin
Operation: file_mmap
Name: /usr/lib/1386-linux-gnu/libvisual-0.4/actor/actor_lv_scope.so
Denied: m
Logfile: /var/log/kern.log

I then add my account and everything is fine until i message someone, that is when it crashes.

Am I missing something here? I’ve searched the appropriate wiki page yet can’t find anything to reference it.

If you could please advise, that would be great.


There was a bug in the pidgin AppArmor profile. It could not show until now because the library “/usr/lib/1386-linux-gnu/libvisual-0.4” was not used by Pidgin until Whonix 9.

It’s fixed on this side. In the meantime, you can run

sudo /etc/apparmor.d/aa-disable usr.bin.pidgin

When the update becomes available, run

sudo /etc/apparmor.d/aa-enforce usr.bin.pidgin

to re-confine Pidgin.

For a long time now, I have been using the profiles from github, that is the ones I’m maintaining. It seems that there are some discrepancies between the Whonix apt repository and the master repository on github.

The Pidgin profile had a bug, but for instance, the tor Browser profile installed with “apt-get install apparmor-profiles-whonix” is not updated for TBB 4.0.

And the Gwenview and Okular profiles are not installed.

The discrepancies get quite technical. Therefore answered here:
And here:

sudo /etc/apparmor.d/aa-disable usr.bin.pidgin

Hi, I get this error message when I try that command

sudo: /etc/apparmor.d/aa-disable: command not found

I really would like to get pidgin working but It still throws up those error messages and logs me out when I try to message OTR.

Any ideas on what I can do? also you mentioned it will be fixed when the update becomes available, may I please ask if that will be coming soon?


Very sorry. Run

sudo aa-disable /etc/apparmor.d/usr.bin.pidgin

And to confine Pidgin

sudo aa-enforce /etc/apparmor.d/usr.bin.pidgin

igotwhonixd: that issue might get fixed by a package upgrade in one or two weeks. Stay tuned.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]