Apparmor preventing Tor Browser from Starting


Using WHONIX+QUBES and running Whonix 11 and latest Qubes.

I started this by manually removing all 16 apparmor profiles I found that were loaded from both the whonix workstation and gateway VMs. Then I did

sudo ap-get update sudo apt-get purge sudo apt-get autoremove

afterwards I rebooted and I get the same thing.

Now when I run

I get:

user@host:~$ sudo aa-status apparmor module is loaded. 4 profiles are loaded. 4 profiles are in enforce mode. /home/**/tor-browser_*/Browser/firefox /home/**/tor-browser_*/{Browser/,}start-tor-browser /usr/bin/pidgin /usr/lib/virtualbox/VirtualBox 0 profiles are in complain mode. 0 processes have profiles defined. 0 processes are in enforce mode. 0 processes are in complain mode. 0 processes are unconfined but have a profile defined.

I cannot run any tor browser from any workstation have tried 3 so far. I also cannot remove:

/home/**/tor-browser_*/Browser/firefox /home/**/tor-browser_*/{Browser/,}start-tor-browser

If I run:

sudo aa-disable /home/**/tor-browser_*/Browser/firefox sudo aa-disable /home/**/tor-browser_*/{Browser/,}start-tor-browser

I get:

user@host:~$ sudo aa-disable /home/**/tor-browser_*/{Browser/,}start-tor-browser Profile for /home/user/tor-browser_en-US/Browser/start-tor-browser not found, skipping /home/**/tor-browser_*/start-tor-browser does not exist, please double-check the path.

What I originally wanted to do is disable and remove all apparmor profiles and then re-download / enable them again to see if that fixes the issue. Right now I am running the TOR Downloader to see if a freshly minted Tor Browser will work.


DAMN!!! Even a freshly downloaded Tor Browser using Whonix’s Tor Downloader gives me the same issues. I have already disabled the stable and developers repositories and enabled the tester’s repository. What the hell can I be missing!?


Redownload of torbrowser most likely won’t help.

The shell expands *. Try using single quotes.

I don’t think the profile in the repository is ready for Qubes yet. Maybe the latest version in git is. I try building the package and uploading the the repository sometime later today.

In meanwhile you can try installing it from source code.


Thank you for the reply patrick! I alreaady fixed it. You are right the current repo is not ready!

To fix it I got the latest commit for both firefox and start tor browser commits on github and i deleted the old file and recreated it using what’s on github that worked perfectly. I will post a workaround with better instructions in the mean time as it took an hour to figure it out. Might as well save others some time :slight_smile:

Thank you so much for all the work you and the other contributors do!!


I am wondering if we should take this as suggestion to change the filename to something not using ‘*’.


I’m seeing the exact same problem. After installing profiles for Tor browser I keep getting permission denied errors.