[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Apparmor="DENIED" operation="open" parent=13289 profile="/usr/bin/i2prouter"


#1

i have done these instructions to make i2p working , according to their site of debian instructions to make i2p work , u can find what i did in this link:-

https://www.whonix.org/forum/index.php/topic,1202.15.html?PHPSESSID=e5efbtl97onhfhtv3qpgtt9a5v9isjpu

the tor never started and many messages been shown from the notifications here r they:-

(u can say that these messages r specific to i2p configurations)

[code]May 11 22:47:10 host kernel: [ 6613.384260] type=1400 audit(1431384430.319:77): apparmor=“DENIED” operation=“open” parent=13289 profile="/usr/bin/i2prouter" name="/dev/pts/0" pid=13290 comm=“ldd” requested_mask=“rw” denied_mask=“rw” fsuid=1000 ouid=1000

May 11 22:47:10 host kernel: [ 6613.389788] type=1400 audit(1431384430.323:78): apparmor=“DENIED” operation=“open” parent=13246 profile="/usr/bin/i2prouter" name="/dev/pts/0" pid=13297 comm=“ldd” requested_mask=“rw” denied_mask=“rw” fsuid=1000 ouid=1000

May 11 22:47:10 host kernel: [ 6613.398141] type=1400 audit(1431384430.331:79): apparmor=“DENIED” operation=“open” parent=13308 profile="/usr/bin/i2prouter" name="/proc/1/stat" pid=13309 comm=“ps” requested_mask=“r” denied_mask=“r” fsuid=1000 ouid=0

May 11 22:47:10 host kernel: [ 6613.398150] type=1400 audit(1431384430.331:80): apparmor=“DENIED” operation=“open” parent=13308 profile="/usr/bin/i2prouter" name="/proc/2/stat" pid=13309 comm=“ps” requested_mask=“r” denied_mask=“r” fsuid=1000 ouid=0

May 11 22:47:10 host kernel: [ 6613.398156] type=1400 audit(1431384430.331:81): apparmor=“DENIED” operation=“open” parent=13308 profile="/usr/bin/i2prouter" name="/proc/3/stat" pid=13309 comm=“ps” requested_mask=“r” denied_mask=“r” fsuid=1000 ouid=0

May 11 22:47:10 host kernel: [ 6613.398163] type=1400 audit(1431384430.331:82): apparmor=“DENIED” operation=“open” parent=13308 profile="/usr/bin/i2prouter" name="/proc/6/stat" pid=13309 comm=“ps” requested_mask=“r” denied_mask=“r” fsuid=1000 ouid=0

May 11 22:47:10 host kernel: [ 6613.398170] type=1400 audit(1431384430.331:83): apparmor=“DENIED” operation=“open” parent=13308 profile="/usr/bin/i2prouter" name="/proc/7/stat" pid=13309 comm=“ps” requested_mask=“r” denied_mask=“r” fsuid=1000 ouid=0

May 11 22:47:10 host kernel: [ 6613.398177] type=1400 audit(1431384430.331:84): apparmor=“DENIED” operation=“open” parent=13308 profile="/usr/bin/i2prouter" name="/proc/8/stat" pid=13309 comm=“ps” requested_mask=“r” denied_mask=“r” fsuid=1000 ouid=0

May 11 22:47:10 host kernel: [ 6613.398183] type=1400 audit(1431384430.331:85): apparmor=“DENIED” operation=“open” parent=13308 profile="/usr/bin/i2prouter" name="/proc/9/stat" pid=13309 comm=“ps” requested_mask=“r” denied_mask=“r” fsuid=1000 ouid=0

May 11 22:47:10 host kernel: [ 6613.398190] type=1400 audit(1431384430.331:86): apparmor=“DENIED” operation=“open” parent=13308 profile="/usr/bin/i2prouter" name="/proc/10/stat" pid=13309 comm=“ps” requested_mask=“r” denied_mask=“r” fsuid=1000 ouid=0
[/code]


#2

“the tor never started” -> Super confusing. Probably you mean “Tor Browser never started”?

Whonix doesn’t ship a /usr/bin/i2prouter apparmor profile.

You can either:

  1. reduce security, disable that apparmor profile.
  1. reduce even more security. totally disable apparmor (probably not required).

  2. Or contact upstream (here: i2p) about this issue.

  3. Adapt the apparmor profile yourself.


#3

yes sorry , i mean tor browser.

i will use the command and c if its going to work , if not, then i will contact the i2p forum and c what they gonna do about it.

i will give the feedback here.


#4

yes , it worked , peers connected.

but as u know its a UDP connection , so i played with global firewall settings (for whonix workstation only part) => now fully wokring :slight_smile:


#5

See also: