[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Apparmor and sdwdate whonix 11 conflictions


#1

hi there , i have installed the apparmor profiles to whonix 11 with tester repository. and then i have restarted both of them, non-stop/continues error messages popping up in both whonix gateway&workstation, images:-

whonix gateway:-

whonix workstation:-

apparmor stopped working and the problem is persistent, this is a photo for the apparmor:-

sorry i cant even use the terminal because both of them (ws&gw) r extremely laggy nearly to freeze situation, c this image:- (btw this is one terminal opened not 3)

also there is one thing forgot to mention but i donno if its the cause or not. firstly the apparmor profiles installation where from the clearnet ,after been finished i shutdown both ws&gs then i pipped the virtualbox through the vpn then i run both of them again. then i got these errors.

simple:-
whonix ws&gw downloaded&installed using clearnet -> the apparmor
shutdown both
pipped ws&gw through vpn connection but before they start (which mean from the host vpn)
start ws&gw
boom there u gonna c it.

i donno if this is related or not but im just telling every single step i have done before that happened

Edit by Patrick:
fixed typo in subject


#2

For Whonix 11, until it’s released… Don’t use the testers repository. It’s still reflecting Whonix 10.

Keep the stable repository for Whonix 11. It actually contains more current AppArmor packages than the testers one.

Technical reason:
I cannot update the testers repository at this time, because most are still Whonix 10 / wheezy users. For jessie packages, one needs to go through https://www.whonix.org/wiki/Upgrading_Whonix_10_to_Whonix_11 first. Otherwise it would break dependencies.


#3

oh i c , thought the process of migrating the packages from Developer->Tester->Stable. thought the stable going to have the least packages but more effective one and least to no error conflicts.

but any how i fixed it by fastly when the system load i open terminal and type sudo whonix_repository then change to stable then sudo apt-get update then dis-upgrade because if im going to take time in that i cant do anything after (going to be very laggy to freezed situation). and the poor system cant handle that, because look at the error messages capacity the system recorded:- (568 denied message)


#4
oh i c , thought the process of migrating the packages from Developer->Tester->Stable. thought the stable going to have the least packages but more effective one and least to no error conflicts.
That's the plan, but codenames upgrades (wheezy -> jessie) are more complicated and cannot be shared among codenames.

#5

same error here. so stable repo is the recommended one?

might want to edit wiki, it says use testers


#6

There is no fix yet.


#7

Testers repository was updated.
https://www.whonix.org/forum/index.php/topic,1521.0.html

Please try.


#8

excellent , i will try and give u feedback.


#9

Great!

[quote=“TNT BOM BOM”]http://i.imgur.com/9UtWubf.png

should i delete and re-install the apparmor profiles ?[/quote]
Split here:
https://www.whonix.org/forum/index.php/topic,1593.0.html


#10

the split link changed to:-

https://www.whonix.org/forum/index.php/topic,1594.0.html

sorry by mistake deleted that topic and i have re-posted again.


#11

I had to disable the sdwdate profiles cause it was causing an issue. When i first load the vms everything works ok and it timesyncs. but when it rechecks after a while i get errors and then it does not complete so I disabled it for now.