[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

[Answered] WORKST. CONSOLE ERROR (KDE-KDM)

Hello there,see much positive changes in forum from my last login.

Have quite a difficult error,when i trying to compile some application,i guess accidentally reinstall X11 packet,maybe this one-libx11-6,dont remember exactly.
Then after rebooting try,workstation just locked,so i switch off the machine.

When i tried to boot workstation have the following:

[INFO] [RAM Adjusted Desktop Starter] Starting login manager (graphical desktop environment) kdm…
[ERROR] [RAM Adjusted Desktop Starter] Could not start kdm.Please report this Whonix bug!
[INFO] [whonixcheck] A package manager is currently running. (’‘apt-get dist-upgrade --simulate’'exit code:100)
waiting for it to finish…

If there is any possibility to fix this from console or maybe some other way?

Please try this and tell us what it said and if it worked.

sudo apt-get update
sudo apt-get install kdm
sudo apt-get install whonix-shared-desktop-kde
chmod +x /etc/init.d/kdm
sudo service kdm start

Yes,i tried,there was some problems with dpkg/lock i move them with ps -e | grep apt and sudo kill process,as i suppose,must be reinstall libx11-6 (2.1.5.0) default to (2.1.6.0-1) newer version,so cant right now install sudo apt-get install kdm.

Got 2 screenshots uploaded,maybe there is some way,back to default libx11-6 (2.1.5.0) (if problem really in it) or maybe install from USB,like you know,when installing Debian as host system,it may need proprietary driver for network card or some other.

Also apt-get update is working fine,reboot nothing,apt-get -f install the same.When tried to delete libx11-6 and libx11-dev have message,about dependency of many applications from them.

Did you run “sudo apt-get update” beforehand?

It suggested to run “sudo apt-get install -f”, liberally, not “sudo apt-get install -f kdm”. Try the “sudo apt-get install -f” please.

Did you install other packages sources, such have you attempted to install packages from debian testing or other repositories?

Sure,it goes fine.

“sudo apt-get install -f” the same (libx11-6 depends libc6 ) and so on like in 2nd screencap.

Yes,i install or reinstall x11 libraries from .deb packet manually,not from repository,i guess more newer version,not for wheezy,but right now i cant recognize(i have stable wheezy whonix).

I tried already all possible ways,which able to find along all this time.For system work,need installed kdm,right,but it is impossible because of library dependencies,and the worst is that they are system very important libraries.
Package: libx11-6 (2:1.5.0-1+deb7u1) https://packages.debian.org/wheezy/libx11-6
that i used to have initially,but as see from system information,i have 2.1.6.0-1 installed,its not even jessie,sid or squeeze,i dont understant how i get it.When i reinstall x11,it might broke the whole system.

I googled libx11-6 (2.1.6.0-1) and have only 2 results,which 1 is this thread.If it be worthless of time spent on this broken system,i just delete it,but have importart bookmarks saved on TBB and some settings and logs from xchat,and also impostant for me info.Yeah,this is difficult puzzle.

libx11-6 - This package provides a client interface to the X Window System, otherwise known as ‘Xlib’. It provides a complete API for the basic functions of the window system.
libx11-dev - X11 client-side library (development headers)
libc6 - Embedded GNU C Library: Shared libraries

Installing packages manually not using apt-get is a bad idea:

  • can break dependencies, which is difficult to repair (you could try general linux forums though, they have greater skills guiding you through fixing this)
  • difficult to verify packages being signed (to check that no man-in-the-middle attack added malicious additions)

I guess backup and restore in a new VM is the more time efficient way.

I see,it have sence,im only doing this,because of old program code (10-12 y.old)which try to build.

Patrick and the last,what you mean by ‘backup and restore in a new VM’ maybe i dont know some important VB features,just copy all data from old machine to new one,really so?

Im ready to delete this system,only need to backup data from there.

Sorry, there is no convenient way to get your data out of the VM. We documented them here:

Then get the data into the new vm.

Ok,thanks anyway,ill keep trying.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]