Always timeout with default settings


I am trying to use Whonix Gateway in an VM, but I couldn’t get it working.
The settings are default. I always get this error after WhonixCheck:

Link to picture: http://up.picr.de/26732499ie.jpg

Does anyone know a solution?
This is really frustrating.


Please answer the questions asked in that screenshot as well as try the recommendations listed there.



  1. Tor Browser works perfectly fine on the host machine.
  2. This error always appears when I run WhonixCheck
  3. Here are screenshots of arm (Connection page is empty):

Hosts internet is working.
I live in middle europe, normally there is nothing censored.
I found out that it could be in a relationship with the clock???



( https://www.whonix.org/wiki/Tor_Controller#Arm_FAQ )

Yes. Host clock must be reasonable correct. (Up to +/- inaccuracy is not great but should still work.)

Is your host clock reasonable correct?


The clock of the host and of whonix are now nearly perfect equal.
But it didn’t change anything. I still get the same error.
The hosts (Windows 10) clock is set over Microsoft’s time server.


Does Tor’s log show anything interesting? ( https://www.whonix.org/wiki/Tor#Log_Analysis )

Does user clearnet have working internet connection? You can check that as per:

If not, can you try please if other non-Whonix VMs (such as Debian jessie) have working internet?


The log since the last boot shows this:

  1. http://up.picr.de/26754999px.jpg
  2. http://up.picr.de/26755010ic.jpg
  3. http://up.picr.de/26755015st.jpg

When I tried a connection to check.torproject.org nothing happened (is there even a timeout?).
Removing write protection from /etc/resolv.conf gave the error “Operation not supportet while reading flags on /etc/resolv.conf”.
Restarting networking gave the error “Could not find the database of available in /usr/sbin/service”.
The nameserver of /etc/resolv.conf isn’t, it’s for me (localhost).
The dns lookup for google timed out.


So far:

  1. Internet works on host.
  2. TBB works on host.
  3. No clearnet connectivity on Whonix-Gateway.

Determine if it’s a Virtualbox-related issue or a Whonix-Gateway issue:

Also, are you sure you didn’t change the VM network settings in Virtualbox? Is Whonix-Gateway set to NAT on eth0?


Actually instructions could not work as they were. Updated now. https://www.whonix.org/wiki/Troubleshooting#As_user_clearnet

(chattr, service requires sudo.) Please try again.


VirtualBox settings are all default. And yes, its NAT on eth0.
Even wih a sudo at the chattr command I get the error:
“chattr: Operation not supported while reading flags on /etc/resolv.conf”

I already imported the .ova file mutiple times, it’s not working on any machine.


These instructions are problematic.

  1. chattr doesn’t work on symlinks (but not needed anyway - +i is not set)
  2. dhcp does not overwrite resolv.conf
  3. not sure if you want to advise manually editing resolv.conf

This command doesn’t rely on dns:
UWT_DEV_PASSTHROUGH=1 curl --tlsv1.2 --proto =https -H 'Host: check.torproject.org' -k
If it doesn’t work, then you have no TCP connectivity in your Gateway VM.

You need to install a non-Whonix VM - linux, windows, etc - and see if networking works in virtualbox at all. No point discussing further until you do this.


Right. Removed chattr and resolv.conf editing. Only left the check.torproject.org curl tcp-only connectivity test.


curl: (7) Failed to connect to port 443: No route to host

I have multiple other VM’s, like Windows 7, Ubuntu and Linux Mint. Every machine has a working internet connection when set to NAT on eth0.
It’s just the Whonix-VM which won’t work.
The network adapters are activated.


You must enter command as user clearnet.

sudo su clearnet

then try curl again.

It should work if your other Virtualbox VMs have connectivity.

If it’s successful, open a terminal and type whonixcheck. If whonixcheck times out after 2 minutes, do it again.


Simplified that a bit more. Actually, there is no need for “sudo su clearnet”. Can be one line.

@Gaghunfv2 please try the following command.

sudo -u clearnet UWT_DEV_PASSTHROUGH=1 curl --tlsv1.2 --proto =https -H 'Host: check.torproject.org' -k


i tried the command.
After I press Enter, I get the following:
curl: (7) Failed to connect to port 443: Connection timed out