[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Allow usage of default network on Whonix Gateway

I need to route the Whonix Gateway traffic through my VPN, which uses interface tun0 with OpenVPN. Unfortunately, the Whonix Gateway only seems to work using the “external” network, bypassing the VPN. I even enabled and started the default network for qemu:///system and performed multiple reboots, but the Whonix Gateway still won’t connect on “default”, with or without the VPN connected. Is there a fix for this?

Did you see

?

Yes, however I was looking for a technical answer in regard to Whonix with KVM working over a regular internet connetion, so as not to override interface tun0. I have read much of the Whonix documentation and it is very well written and informative. However, Whonix on KVM seems to bypass any VPN I may put on my system, and I have spent countless hours testing and looking for a resolution.

Setting Whonix Gateway to use default instead of external seems to be a possible solution, but there is seemingly no internet connection over “default” as there would be on other VMs over KVM.

This was the most helpful thing I could find: Connecting_to_a_VPN_before_Tor#On_the_Host

However, it did not address the issue, since KVM Whonix bypasses OpenVPN on the host.