[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Allocate more memory for workstation


#1

Hey there.

I just installed Whomix via KVM.
Everything runs fine but it seems that my workstations is a bit slowly. So i checked how many ram is allocated to it.
Its just 1GB. Since my host has much more, I would like to use more.

If I try to allocate more via the Virtual Machine Manager gui it tells me:
Angeforderte Operation ist nicht gültig: Kann nicht die Größe des maximalen Speichers auf einer aktiven Domain ändern

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 2326, in _change_config_helper
    self.vm.hotplug(**hotplug_args)
  File "/usr/share/virt-manager/virtManager/domain.py", line 986, in hotplug
    _hotplug_maxmem(maxmem)
  File "/usr/share/virt-manager/virtManager/domain.py", line 960, in _hotplug_maxmem
    self._backend.setMaxMemory(val)
  File "/usr/lib/python2.7/dist-packages/libvirt.py", line 2180, in setMaxMemory
    if ret == -1: raise libvirtError ('virDomainSetMaxMemory() failed', dom=self)
libvirtError: Angeforderte Operation ist nicht gültig: Kann nicht die Größe des maximalen Speichers auf einer aktiven Domain ändern

How can I change the allocated memory for my Workstation?


#2

Good day,

please regard this: Kvm + whonix 11 slowness

At the moment, adding more memory doesn’t impact performance beneficially, as any slowness is sadly a result of the virtualized graphics united, which can’t be improved upon at current times.

Have a nice day,

Ego


#3

You can change it by going to virt-manager -> Whonix-Workstation settings -> Memory -> raise limt from 1024 to 2048 mb