[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

after fresh install Whonix 15.0.0.6.6 shared clipboard stops working after updating

I did a fresh install Whonix 15.0.0.6.6 / Virtualbox. I can get everything working great BUT then after all the updates are installed, it breaks Virtualbox Guest Additions shared clipboard. I have now done three fresh installs and this issue happens every again. All features of Guest Additions work on the first couple boots on both the Workstation and Gateway. Everything looks normal but when you paste nothing happens. It does not work from host - guest or vice versa. Shared storage drag and drop both work fine. Also updated virtualbox and Guest Additions but that has not working either.

I have been battling with this off and on for two days and I’m really hoping someone knows how to fix this. I have read every related article via whonix, virtualbox and maybe Google too! :grimacing:

Console: Machine state changed to ‘Starting’
00:00:04.140155 Qt version: 5.6.2
00:00:04.144842 GUI: UIMediumEnumerator: Medium-enumeration finished!
00:00:04.312247 SUP: Loaded VMMR0.r0 (C:\Program Files\Whonix\VMMR0.r0) at 0xXXXXXXXXXXXXXXXX - ModuleInit at XXXXXXXXXXXXXXXX and ModuleTerm at XXXXXXXXXXXXXXXX using the native ring-0 loader
00:00:04.312299 SUP: VMMR0EntryEx located at XXXXXXXXXXXXXXXX and VMMR0EntryFast at XXXXXXXXXXXXXXXX
00:00:04.312318 SUP: windbg> .reload /f C:\Program Files\Whonix\VMMR0.r0=0xXXXXXXXXXXXXXXXX
00:00:04.316912 Guest OS type: ‘Debian_64’
00:00:04.318679 fHMForced=true - SMP
00:00:04.318714 fHMForced=true - 64-bit guest
00:00:04.325216 File system of ‘C:\Users\who\VirtualBox VMs\Whonix-Workstation-XFCE\Snapshots’ (snapshots) is ntfs
00:00:04.325246 File system of ‘C:\Users\who\VirtualBox VMs\Whonix-Workstation-XFCE\Whonix-XFCE-15.0.0.6.6-disk002.vmdk’ is ntfs
00:00:04.328322 File system of ‘C:\Users\who\Downloads\VBoxGuestAdditions_6.1.4.iso’ (DVD) is ntfs
00:00:04.355226 Shared clipboard service loaded
00:00:04.355270 Shared clipboard mode: Host to Guest
00:00:04.372938 Drag and drop service loaded
00:00:04.372982 Drag and drop mode: Bidirectional

This sounds like it relates directly with my issue.

“Please update Whonix vbox guest addition modules”. Unfortunately I can’t link to it.

https://www.whonix.org/wiki/VirtualBox/Troubleshooting#Non-functional_Shared_Clipboard_and_Drag_and_Drop

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]