[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Access control_auth_cookie from workstation?

I’m trying to get DarkMX working in Whonix 16 workstation. It can work with an external Tor client but it requires the “external Tor cookie file” which I take to mean the control_auth_cookie. (Here’s a screenshot of the config menu.) I tried searching the wiki and forums but nothing seemed relevant. I tried setting CookieAuthFile in the Gateway to try copying it over but nyx crashed and complained it couldn’t find /var/lib/tor/control_auth_cookie. I tried resetting Gateway from snapshot (I’m using Virtualbox) and looked for that file but it doesn’t exist.

I don’t really know what to do, I’m not familiar enough with Whonix’s setup to know if this is possible or not.

EDIT: I noticed there’s /run/tor/control_auth_cookie in Workstation, but DarkMX appears unable to set this file, perhaps because it doesn’t own it. I tried copying the file but that doesn’t appear to work either.

Tor ControlPort / ControlSocket is available in Whonix-Workstation…:

…but filtered:

The application probably attempts to use Tor control protocol commands for the creation of an (“ephemeral”) Tor onion service, which is blocked.

The bad news:
This required development skills to make that work. Not likely that anyone else will implement that unless the application has significant popularity. Happened for OnionShare, Bisq, ZeroNet, Ricochet IM. See related documentation and discussion for these applications.

The good news:
Anyone can learn development skills in Freedom Software.

Thank you for the quick reply. I’ll bring this up on the DarkMX forums and see if they can implement an alternative connection method that works within Whonix. Otherwise I’ll see what else I can do.

Do not use your identity for anonymous actions. They way you are writing makes it easy to guess which country you are from. In that country there are only 20000 daily tor users, so you are only 1 of 20000 now and not 1 of 2 million.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]