[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

50_user.conf seems to be COMPLETELY ignored by Whonix

#1

I’m trying to have the same exit node for a specific domain and a specific IP address.
tried “TrackHostExits domain(dot)com” doesn’t work, exit node changes within 10-5 minutes.

tried “TrackHostExits domain(dot)com,1.1.1.1(ip)” and that also didn’t do the trick, to no one’s surprise.

Only conclusion I have arrived at is that the config file is being completely ignored, why? This is beyond me, I re-installed the gateway and still does not work.

#2

Wrong conclusion. See; https://trac.torproject.org/projects/tor/ticket/25412

Using Duckduckgo is a good idea when troubleshooting. For example; searching for key words “Tor TrackHostExits” returns the above answer.

1 Like
#3

re-install is mostly a Windows concept. On Windows:

  1. something broken, don’t know how to diagnose, don’t know how to fix
  2. reinstall Windows
  3. root cause not understood so likelihood of being affected again by some issue is high

With Linux distributions we need re-install a lot less, and we’re much better at diagnosing and fixing bugs, due to Open Source.

1 Like
#4

I was duckducking and googling for 7 hours, opening this thread was a mean of last resort. Checking out the ticket, thanks

#5

If you’re only interested in a specific domain and you don’t mind selecting the exit node manually, one way would be to use the ExitNodes setting in the file on separate Whonix Gateway / Whonix Workstation that are then used to access only this site.

At any case this setting will make it clear whether the file is ignored or not.