[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Whonix XFCE 14.0.0.9.6 for VirtualBox released!

important-news

#24

Which version? 14.0.0.9.8 or 14.0.0.9.6?
On a self build 14.0.0.9.8 KVM image it works.
pavucontrol will be added to the packages.


#25

latest one

KVM with xfce?


#26

Yes.

I also tested now self build vbox images. I indeed had problems running videos. They started but immediately stopped. But after I installed the guest additions and also enabled audio output for the VM (not sure if this matters) it worked perfectly. The guest additions should be installed by default in the official images. Could you check if they are present and also if they match the installed vbox version? Tested version was 5.22 .


#27

#28

NiceXD:

Please add

  • language indicator

Maybe yes. (If it looks ok.) ->

  • audio volume control

This may or may not be done after last pull request and will be included
in over next Whonix (point) release.

  • system monitor

Maybe yes. (If it looks ok, not too much use of disk space, other issues
i.e. no autostart of it.) ->


#29

Not sure…

https://www.whonix.org/wiki/Dev/Default_Application_Policy

  • We must believe that a fair amount of users likes it.
  • We must believe that it is usable by a fair amount of users.

I am wondering if it would benefit more users than confuse. The added value is not clear to justify default installation.


#30

A stupid question: will those last changes be reflected with sudo apt-get update && sudo apt-get dist-upgrade or is it required to download and import the .ova files again?


#31

barbara:

A stupid question: will those last changes be reflected with sudo apt-get update && sudo apt-get dist-upgrade or is it required to download and import the .ova files again?

That’s actually a complex question to answer.

Everything that is very important: Will be reflected by usual upgrades.
Otherwise a separate Whonix news will be posted.

Everything that is not crucial (usability improvements): This includes
changes to everything configured in user’s home folder. Everything that
Whonix has to ship in /etc/skel due to technical limitations. Such as
the change from xfce standard start menu to whiskermenu will not be done
automatically by upgrades. This - if you want this (not important for
anonymity/privacy/security) - you have to do that manually.


#32
apt list | grep virtualbox

virtualbox-guest-dkms/now 5.2.22-dfsg-1~bpo9+1 all (installed, local)
virtualbox-guest-utils/now 5.2.22-dfsg-1~bpo9+1 amd64 (installed, local)
virtualbox-guest-x11/now 5.2.22-dfsg-1~bpo9+1 amd64 (installed, local)

so its the same version.


#33

@Algernon confirmed , just by allowing the audio output for the VM it will work.

@Patrick in WS , is there a reason its not enabled by default ?

thats the workaround to make the videos working.


#34

Pull request required.


#35

#36

To enable thumbnails for image files open Thunar (file manager).
Choose “Edit” on the menu bar and select “Preferences”.
On the “Show thumbnails:” drop-down select “Local Files Only” or “Always”.
Now open a terminal window and enter:

sudo apt-get update && sudo apt-get install tumbler

You may need to restart Thunar file manager for these changes to take effect.


#37

i may have missed this elsewhere. has kde been abandoned in future builds of whonix for virtualbox for the ova files that a user can download from the webpage?


#38

#39

thanks, @Patrick. i saw the poll. but, i didn’t see an official announcement on if a choice had been made. so, has the choice been officially made? i noticed that the downloads section does not offer a kde version. so, before i re-screenshot all of the chapters of the guide i work on, i want to make sure this is in fact the official direction. :slight_smile:


#40

Technically correct.

https://www.whonix.org/wiki/VirtualBox/KDE is still available but no point release was build and won’t be.

The underwhelming (speak zero) request for Whonix KDE makes it very unlikely to see a revival of KDE. So with Whonix 14 -> Whonix 15 (buster) upgrade everyone has to move to CLI or XFCE or be unsupported.