[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix Workstation Hangs - Browser Lag On Ryzen CPU - Solved!

Once you open the browser, after a few minutes the entire work station hangs and you have to start another instance. This has happened every time I have tried using it on Ryzen.

Also the performance of station is really weak. For example, you experience lag at every page. On Intel, no issues present. Host PC is powerful enough to deal with Whonix. Surprisingly Gateway works without any issue!

Hope you would help and short this out soon.Thank you again for all of your hard work.

  • Woody

Update: July 31, 2018
Found out that the moment you maximize the Workstation window by dragging VBox window corners, it hangs.

Solution:
Resize the window not by dragging the Virtual Box corners but by using View > Virtual Screen 1 option just after the initial boot. Once resized like this, you can drag window corners as required without any hang. But there is a good chance of getting the Workstation freeze again by this method. So try and use suggested option for now.

What hypervisor are you using? Perhaps its a bug that causes it to underperform. Also from your description its most likely something we can’t help with and would need reporting to upstream projects like Tor Browser to troubleshoot.

Hi rockwood

Since Whonix starts and connects to Tor with no problems I don’t think this is a Whonix issue. Its more likely a RAM issue. Do you have enough RAM for your host and both Whonix VMs ?

When using Whonix try shutting down all not essential processes on your host. You can also add more RAM with rads

If you have limited RAM try decreasing Whonix-Gateway to 512MB and adding the difference to Whonix-Workstation.

Another option, depending on your answer to HulaHoop (i.e. what hypervisor your using) you can also increase RAM in the virtual machine

1 Like

Hosted hypervisor - VBox.
Entire Workstation hangs though. Not just TB.

Have 16 GB RAM.
Issue comes within few minutes of launching Workstation, browser.

Buggy as hell

you should try an alternative (the Qubes or KVM port) otherwise you won’t get it off the ground

How much RAM do you have allocated to the VMs? Issue could be from opening additional browser tabs (more RAM needed)

1 Like

Used to work just fine on a 4 year old Intel with 8 GB RAM. Only now it has issues. About the tabs, freezes with just one tab. I will try allocating more RAM but never had I to add before.

Update: Added more RAM. No go!

Have to have Windows.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]