[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Whonix Workstation CLI-15.0.1.5.4 - Automatic logon in the system at startup

Hello,
I’m seeing that, when I start Whonix Workstation or I reboot it, by default it never asks me the credentials but it logons directly, even if I change user password.

This behavior is here from the beginning. I didn’t install Whonix Workstation but I used .ova file and imported it to VirtualBox.
In my opinion, directly logging on without asking credentials, make some security concerns.

In the Settings, I don’t see any configuration for enabling/disabling the automatic logon. But this automatic logon was already enabled when I imported the .ova file on VirtualBox and continue to be also if I change password.
It could be useful that, the released .ova have this option enabled by default.

Thank you in advance

Autologin is a usability feature.

To disable:
https://www.whonix.org/wiki/Desktop#Disable_Autologin

You need to protect the host instead. Unauthorized access to host means game over.

For the other issue please create a separate forum thread.

Thank you @Patrick.

I edited the title of this post, and moved the 2nd question to this one: Whonix Workstation CLI-15.0.1.5.4 - Not working buttons in Whisker menu

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]